Bug with default culture crashes IIS

 

I have a clean Episerver 7 MVC project created in visual Studio. Modified it to run in IIS instead of IIS Express (Where is the documentation for this?). Configured the site to use two languages ('en' and 'nl') and set the default culture to 'nl' (in 'CMS/admin/config/site information/host names'). This runs fine.

Then installed Commerce R3 using the Episerver Deployement Center. After this step the site crashes constantly. If I remove the default culture everything seems to work again. I traced the problem to the function: 'EPiServer.Business.Commerce.Providers.CatalogEntryPageRoute.OnVirtualPathCreated(Object sender, UrlBuilderEventArgs e)' which returns a null object reference.

I read in several posts that commerce only deals with the 4 letter language codes and not the 2 letter ones. This for me is not an option. Also a default culture is mandatory for the project I am working on.

Is there a way to get 2 letter language working with Episerver commerce?

 

#63843 Nov 30, 2012 15:09
  • Magnus Stråle
    Member since: 1997
     

    Unfortunately we currently (including the Commerce 1 R3 release) do not support non-specific cultures in the EPiServer Commerce Framework. 

    This should be fixed for the next major Commerce release.

    #64246 Dec 14, 2012 9:13
  •  

    I had a similar problem when trying to create my language dropdown. The problem was that the language was created in one language that wasn't enabled in admin mode. Enabling the languages there stopped the error from happening.

    #71324 May 15, 2013 17:01