Build index with Quartz service

Vote:
 

Hi,

I have installed CMS, Commerce with Enoteca sample site and wine catalog, and the Quartz service from the Deployment center.
Without doing any modifications the Quartz service fails on buiding the search index. I can build it successfully manually from within the Commerce admin page. The connectionStrings.config in QuartzService has correct settings. Do I need to changes to the Quartz config to make it work? This is the error it logs;

[ServerScheduler_Worker-1] INFO Mediachase.Search.SearchManager - Build Failed using "catalog" indexer. "The ConnectionString property has not been initialized."
Mediachase.Search.IndexBuildException: Build Failed using "catalog" indexer. "The ConnectionString property has not been initialized." ---> System.InvalidOperationException: The ConnectionString property has not been initialized.
at System.Data.SqlClient.SqlConnection.PermissionDemand()
at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
at System.Data.SqlClient.SqlConnection.Open()
at Mediachase.Data.Provider.TransactionScope.OpenConnection(IDbCommand cmd, String connectionString, ConnectionDelegate connection)
at Mediachase.Data.Provider.SqlDataProvider.ExecuteScalar(DataCommand command)
at Mediachase.Data.Provider.DataService.ExecuteScalar(DataCommand command)
at Mediachase.Commerce.Catalog.Data.CatalogEntryAdmin.StartFindItemsForIndexing(Guid searchSetId, Int32 catalogId, Boolean isIncremental, Nullable`1 earliestModifiedDate, Nullable`1 latestModifiedDate)
at Mediachase.Commerce.Catalog.Impl.CatalogContextImpl.StartFindItemsForIndexing(Guid searchSetId, Int32 catalogId, Boolean isIncremental, Nullable`1 earliestModifiedDate, Nullable`1 latestModifiedDate)
at Mediachase.Search.Extensions.BaseCatalogIndexBuilder.BuildIndex(Boolean rebuild)
at Mediachase.Search.SearchManager.BuildIndex(Boolean rebuild)
--- End of inner exception stack trace ---

#61765
Oct 01, 2012 15:45
Vote:
 

I think the Mediachase.Quartz.Service.exe.config does not have the config source for connection string pointing to connectionstring.  Check the config file of the service is setup correctly.  Remember to restart the service anytime you chnage config settings to be safe it is updated before the next job

#61969
Oct 09, 2012 2:58
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.