Default CSS classes still visible in TinyMCE EPiServer 6 R2

Member since: 2010

I removed the css class property from TinyMCEPluginNonVisual, because it didn't work (only the episerver default classes were present in the dropdown) in TinyMCE editor.

Instead, I put it inside the episerver.config : uiEditorCssPaths="~/Styles/tinymce.css"

Now, they are added to the dropdown, but the default ones are still there.

Any recommendations on how to remove the EPiServer classes?

#53256 Sep 02, 2011 15:38
  • Member since: 2010

    Anyone?

    #53424 Sep 08, 2011 11:31
  • Two ways to override the path to the stylesheet either in episerver.config by setting the uiEditorCssPath attribute or by adding a dynamic property with the name UIEditorCssPaths with the path to the editor stylesheet. If you're still seeing the default stylesheets after that try doing an IISreset and closing/reopening your browser.

    Hope this helps.

    Frederik

    #53425 Sep 08, 2011 11:53
  • Hi Marija!

    Makes sure your css files follow the following guide:

    http://world.episerver.com/Documentation/Items/Tech-Notes/EPiServer-CMS-6/EPiServer-CMS-6-R2/TinyMCE-Developers-Guide3/#EPiServerCSSAttributes 

    #53427 Sep 08, 2011 13:39
  • Member since: 2010

    Hi, guys, thanks a lot for your time and effort!

    @Frederik, these things were set.

    @Toni, this helped, it's working now properly!!! I didn't think I had to set these, as my styles were visible in the dropdown.

    #53429 Sep 08, 2011 14:01