Filter on Connector name



I'm new to Episerver.Find. I tried finding a solution to my problem here in the forums and on google, but I didn't find anything.

We are trying to move a existing Episerver site to Episerver DXC.
The site are currently using SiteSeeker as a search engine, but when moving to the cloud we want to change to Episerver.Find.

Currently the search functionality search the current Episerver site, but also crawling 3 other sites. On the search page we have a tab each for these 4 sites, each with it's own hit count and list of results.
I have set up an index in Find and added three connectors to the other sites.

I want to be able to filter the results on each of the tabs.
After some searching I have found that the SearchSection property should have the name of the connector that have indexed each of the results. But when I try to filter on SearchSection I get nothing in result.

When I do a UnifiedSearch I get hits from all sites, but as soon as I try some kind of filter I get 0 hits.

Anyone got any suggestion how to solve this?

Mar 07, 2019 9:54


How are you filtering the results? If you can determine that the result is crawled WebContent you should be able to read its SearchSourceName wich is the name of the connector that was used to crawl the site. 

Something like this:


 var allResults = unifiedSearch

foreach(var result in allResults){

if (result.OriginalObjectType.Equals(typeof(WebContent))){

var content = result.GetOriginalObject<WebContent>();
var source = content.SearchSourceName;
//Create hit here

Mar 07, 2019 11:55


I didn't get your code to work.

But I got some help and used the HitUrl as filters and used the "prefix" options to filter the different sites the connectors is crawling.
So now I do 4 different searches with the same index, and filter on different prefixes (domain) for each of the crawled sites.

Mar 07, 2019 13:40
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.