Error trying to fetch more than 100 items

Vote:
 
We are using an on premise find solution. We get the following error on our production server, but the same query and database works on our test environment. Does anybody know what could cause this?
The index is set to return 1000 items. Could this be some kind of setting on the find server itself?

System.Web.HttpUnhandledException (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> EPiServer.Find.ServiceException: The remote server returned an error: (403) Forbidden. Your account is not authorized to return more than 100 hits ---> System.Net.WebException: The remote server returned an error: (403) Forbidden. at System.Net.HttpWebRequest.GetResponse() at EPiServer.Find.Connection.JsonRequest.GetResponseStream() at EPiServer.Find.Api.Command.GetResponse[TResult](IJsonRequest request) --- End of inner exception stack trace --- at EPiServer.Find.Api.Command.GetResponse[TResult](IJsonRequest request) at EPiServer.Find.Api.SearchCommand`1.Execute() at EPiServer.Find.Client.Search[TResult](SearchRequestBody requestBody, Action`1 commandAction) at EPiServer.Find.SearchExtensions.GetProjectedResult[TResult](ISearch`1 search, SearchContext context) at EPiServer.Find.SearchExtensions.GetResult[TResult](ISearch`1 search) at EPiServer.Find.Cms.SearchRequestExtensions.GetContentResult[TContentData](ITypeSearch`1 search, Int32 cacheForSeconds, Boolean cacheForEditorsAndAdmins)
#201314
Feb 13, 2019 11:25
Vote:
 

You should be able to increase 'max_search_size' config entry to 1000 on the server.
If it's not possible your Find on premise might be very old.

#201374
Edited, Feb 15, 2019 16:13
Vote:
 

Hi

Do you know in which config file this should be set?

#201723
Feb 28, 2019 12:48
Vote:
 

This was resolved by setting the max_search_size to 1000. This was choosen when the index was created, but did obviously not get registered.

This is possible to do directly on the index (thanks BV Network). 

Further runtime settings are stored in a special `@admin` index, mainly for use
by the `es-proxy` service. The settings are normally viewed and adjusted through
the web index admin interface, but can also be accessed directly:

    $ curl -XGET "http://localhost:9200/@admin/_search?pretty"

And even updating the relevant `key/_id` document directly:

    $ curl -XPOST \
    > "http://localhost:9200/@admin/key/XXXXXXXXXXX/_update" \

    > -d '{"doc":{"max_search_size":1000}}'

#203495
Apr 25, 2019 10:37