Support for Newtonsoft.Json 11 in Find

Vote:
 

Tried to upgrade to the latest version of Newtonsoft.Json today and did not succed since there is not support for it in Find.

The strange thing is that there are different dependency in the different Find-packages:

EPiServer Find Client API.13.0.1
Newtonsoft.Json (≥ 10.0.3 && < 11.0.0)

EPiServer Find CMS Integration.13.0.1
Newtonsoft.Json (≥ 10.0.3)

EPiServer Find Framework Integration.13.0.1
Newtonsoft.Json (≥ 10.0.3)

When will all three packages be updated?

#192458
May 17, 2018 9:07
Vote:
 

why? :troll:

#192503
May 17, 2018 15:21
Vote:
 

 Because! #troll

#192508
May 17, 2018 16:37
Vote:
 

Extending the verison range is dev complete and should go into the next release that goes to QA.

IMO it is sensible to have a upper limit for the version range so that you only support majors that you have verified, because you simply don't know what APIs will be broken in a future major release. I know there are different opinions about this.

I agree it looks a bit odd that they are different, but in practice the upper range from the EPiServer.Find package will work as upper range of the other two because of their internal depenencies.

#192512
May 17, 2018 21:57
Vote:
 

think "complain" was more for the case that CMS already supports, but because of find packages, upgrade is/was not possible.

#192513
May 17, 2018 22:03
Vote:
 

Oh, I didn't take anything in this thread as complaint. My comment on differing opinions was a preemptive one.

About CMS being ready and not others it is the same discussion as when we do new majors of our own products (although arguably with a 3rd party dependency like this we can and do work more in parallel). There are only two options: Release lower level packages as soon as they are ready or keep them on hold until higher level, dependent, packages have been adapted too. I prefer the former since that benefits the solutions that don't use the higher level packages sooner.

#192515
May 17, 2018 22:32
Vote:
 

Thanks for the information Magnus!

#192518
May 18, 2018 6:59
Vote:
 

Newtonsoft.json 11 will be supported withing a few weeks, FIND-3511. The incorrect nuspec configuration will also be fixed at the same time.

#192519
May 18, 2018 8:10
Vote:
 
<p>Great Jonas! Thanks!</p>
#192520
May 18, 2018 8:27
Vote:
 

This is now out and is working great, are running the latest version of both Find and Newtonsoft.Json!

#197560
Oct 07, 2018 20:58
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.