401 Exception When Indexing Site?

Vote:
 

Hi all - 

I'm getting this error for every piece of content in my site that I try to index using Episerver Find's index job:

An exception occurred while indexing content [Link ###] [GUID ##############] [Type TYPE] [Name NAME]:
The remote server returned an error: (401) Unauthorized. Unauthorized (see log for more information)

  1. I triple-checked all my configs... they seem right, in fact I followed the directions here
  2. This site is using CMS + Commerce, and I installed the 3 NuGet packages listed here
  3. I've never indexed the site before - brand new installation / first time indexing

Has anyone else dealt with this?

#186461
Edited, Dec 20, 2017 2:39
Vote:
 

Do you get this error if you just publish content and not run the scheduled job? Do you set timer for the job or do you run it manually?
Might be good idea to enable logging on info level for find to see if there's more information. Without the stacktrace I'm not sure but it could just be that your index reference is invalid. That you used a 90 day demo that has expired or similar.

#186463
Dec 20, 2017 10:05
Vote:
 

Hi Sebastian - Thank you for your response!

Publishing content works fine - job running on a timer/manual, doesn't matter, errors are the same ...

My index is only a week or two old, but at your suggestion I created a new one and plugged the new index info into all my configs.... somehow that worked! Magic.

Thank you again for your help, I would not have thought to try a new index so soon without your assistance.

Kayla

#186491
Dec 20, 2017 16:30
Vote:
 

@Kayla did you find the solution to your problem?

#191904
May 02, 2018 15:15
Vote:
 

I think is related to the issues Episerver operations have had with Find indexes recently, see: https://world.episerver.com/forum/developer-forum/EPiServer-Search/Thread-Container/2018/4/serious-problems-with-developer-index/

#192020
May 03, 2018 15:16
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.