Looking up dl.episerver.net/...

Vote:
 

Hi,

I've just upgraded a project to the latest version of EPiServer and Find and all pages take ages to load which looks like it's caused as it's trying to look up "dl.episerver.net/..." which I believe is related to Find. The site is on a dev VM which does not have internet access and can not have internet access and I won't be able to get anything opened up to allow the lookup of this.

Is there an 'offline' solution to either prevent this lookup or have the files it needs locally?

Thanks in advance,

Mark

#148388
May 11, 2016 17:12
Vote:
 

Hi Mark,

Just to check:

Unless you're using an On Prem Find Index, your environment needs internet access to be able to read or write to the Episerver Index as it is hosted on Epis servers.

Currently, browsing to the Episerver Find UI (http://yourhost/EPiServer/Find) will load resources such as stylesheets and javascripts from dl.episerver.net while the Edit UI (http://yourhost/Episerver/CMS) will load these from the local files (except for some Find specific javascript-files that would not be necessary if you only want to work with your website content).

So if you need to work with Episerver Find for your solution I would really recommend to allow your VM to have internet access.
When I'm working on a VM I usually create a network bridge in my VM software to make the virtual machine to connect to my network as if it was a physical computer accessing it.

#148443
May 13, 2016 0:14
Vote:
 

Hi Alf,

Thanks for your reply, that's useful information. I forgot the crucial piece of information that we are using the on premise version of Find so internet access is not needed and locked down (and will not be allowed). Have you any experience of this scenario?

Thanks,

Mark

#148514
May 16, 2016 13:18
Vote:
 

If you have an on-premise solution you should update your web.config to use the UI hosted on your on-premis setup:

<episerver.find.ui clientSideResourceBaseUrl="http://[ip to Find VA or loadbalanced ip]/$version$/" />

/Henrik

#148690
May 20, 2016 8:50
Vote:
 

Hi Henrik,

Thanks for that how do I register the episerver.find.ui section in the web.config (in configSections)?

Thanks,

Mark

#163453
Oct 20, 2016 17:11
Vote:
 
<section name="episerver.find.ui" type="EPiServer.Find.UI.FindUIConfiguration, EPiServer.Find.UI"/>
#163456
Oct 20, 2016 18:10
Vote:
 

You also can customize how tracking scripts are injected and loaded on your site pages. Please see details in this blog post.

#163481
Oct 21, 2016 9:29
Vote:
 

Thanks Per, I think I'm one step closer but I now get an error on

<episerver.find.ui clientSideResourceUrl="http://[serverIP]/$version$/" />

stating that the clientSideResourceUrl attribute is not recognised, any thoughts?

Thanks,

Mark

#163739
Oct 21, 2016 10:26
Vote:
 

That should be clientSideResourceBaseUrl

#163740
Oct 21, 2016 10:29
Vote:
 

I think it's "clientSideResourceBaseUrl", not "clientSideResourceUrl"

#163741
Edited, Oct 21, 2016 10:31
Vote:
 
<p>Dmytro beat me to it :-)</p>
#163743
Oct 21, 2016 10:33
Vote:
 

Thanks Dmytro and Per, I should have re-read the earlier comment!

I'm still getting a message when trying to load the backend console of "The Find interface is currently not available". Using firebug I see there is a brief error before the page re-loads with the noconnection page. I've been able to stop the noconnection loading and have found the error is:

Error: scriptError
    _f()dojo.js (line 15)
    req.injectUrl/_10c<()dojo.js (line 15)

    ...rumentRejected&&_2ed.length===0){_2f1.instrumentRejected(_2ee,false,_2ef,_2f0);}...

Any thoughts on this one?

#163745
Oct 21, 2016 10:54
Vote:
 

Ok, I've found out some more information. It seems that some of the scripts being returned from Find are not authorised:

GET http://[Find server]/current/epi/nls/EPiServer.Shell.UI.Resources.JQueryValidate.js 401 (Unauthorized)

GET http://[Find server]/current/epi/nls/EPiServer.Shell.UI.Resources.DatePicker.js 401 (Unauthorized)

GET http://[Find server]/current/epi-find/run.js 401 (Unauthorized)

GET http://[Find server]/current/epi/nls/EPiServer.Shell.UI.Resources.GlobalMenu.js 401 (Unauthorized)

Any ideas on why this might be or how to resolve?

#163768
Oct 21, 2016 11:23
Vote:
 

Is this [Find server] your internal server?

#163770
Oct 21, 2016 11:27
Vote:
 

Yes it is. I think I read somewhere recently about someone having issues as they were using the private Url of their server and they should have been using the public but I'm not sure which I am using (it has the port 8000 though so I would assume it's public?)

#163771
Oct 21, 2016 11:32
Vote:
 

"current" part of URL is a shortcut to latest version of Find UI resources when resources are hosted on EPiServer servers.

Check if these URLs are valid in your environment: http://[Find server]/current/epi/nls/EPiServer.Shell.UI.Resources.GlobalMenu.js

Is http://[Find server]/current/ where you have Find UI resources deployed? Do you have several UI versions deployed on the server?

I think you should use one of these options depending on how Find UI resources are deployed on your server:

<episerver.find.ui clientSideResourceBaseUrl="http://[Find UI resources server]/" />


or something like this if you have several UI versions deployed and need to stick to one of them:

<episerver.find.ui clientSideResourceBaseUrl="http://[Find UI resources server]/12.2.4/" />
#163774
Edited, Oct 21, 2016 11:44
Vote:
 
<p>When I access those URLs in a browser I get a 401 unauthorized. We haven't done anything to deploy resources anywhere we're just using the appliance we were given by EpiServer. Is it possible the appliance hasn't been configured correctly?</p> <p>This is the entry in web.config</p> <p>&lt;episerver.find.ui clientSideResourceBaseUrl="http://[Find server]/$version$/" /&gt;</p>
#163778
Oct 21, 2016 12:33