EPiFind UI login failure

Vote:
 

Hi

I encountered this issue after upgrade EPiServer find to the latest version.  Indexing is still working without any issue, but when click on Configuration and Manage tab, it keeps showing login dialog.

Below are error screenshots 

https://www.dropbox.com/s/962i2ggwheub5nx/login.png?dl=0

https://www.dropbox.com/s/fhak5nbwnz99szm/console_error.png?dl=0

Thanks

#144133
Feb 08, 2016 13:10
Vote:
 

Are you member of both webeditors and searchadmins. Check this url for reference 

http://webhelp.episerver.com/14-1/EN/Content/EN/Find/AccessRightsFind.htm

Might be some custom configuration of access rights that disappeared after upgrade?

#144138
Feb 08, 2016 14:28
Vote:
 

This issue is caused by enable the owin middleware for the authentication. 

Has anyone had a fix for this?

#144183
Edited, Feb 09, 2016 3:31
Vote:
 

I know Marija J on my company did a lot of work with owin and.NET providers.

http://www.mogul.com/om-mogul/blogg/owin-membership-and-role-provider-for-episerver

Check that out first or give her a nudge :)

#144191
Feb 09, 2016 8:42
Vote:
 


Hi Daniel

Thanks for the link. 

I thought from EPi9, it has already supported OWIN out of the box.  I took the OWIN startup class from Quicksilver, and CMS + CM both seemed working. 

I am curious does EPi Find UI authentication work with Owin? 

Thanks

#144196
Feb 09, 2016 9:05
Vote:
 

OWIN + EPi is still new so expect some minor issues like this. I know the plugin for GA has some issues with OWIN as well. 

#144229
Feb 09, 2016 14:20
Vote:
 

Vincent/code monkey: We're currently experiencing this when trying to add best bets, and we too are utilizing OWIN.
Did you ever find a fix for this?

#176923
Mar 29, 2017 23:33
Vote:
 

Hi Stellan,

This issue is fixed and will be available from EPiServer.Find 12.4.2. A release is probably not far away.

#177267
Apr 06, 2017 13:56