Database schema update error when upgrading Find packages

Ted
Member since: 2006
 

I just upgraded the Episerver Find NuGet packages to version 12.2.8.

After restarting the site I get an exception saying: Column name or number of supplied values does not match table definition.

The error seems to occur when one of the SQL statements is executed:

[DataException: Failed to update database during execution of statement 'if exists (SELECT * FROM INFORMATION_SCHEMA.TABLES WHERE TABLE_NAME = N'VW_EPiServer.Find.Cms.IndexingQueueReference')
    begin
insert into tblFindIndexQueue select Action, [Cascade], EnableLanguageFilter, Item, Language, TimeStamp FROM [VW_EPiServer.Find.Cms.IndexingQueueReference]
end
']

Has anyone else seen this?

Edit: I tried running the 12.2.8.sql SQL script manually, and it is indeed outputting the error described above. I guess I'll dwell deeper into it... :)

Edit #2: Not sure I'd call it a solution, but the script worked if I modified the syntax to specify the target column names explicitly. In other words, I changed this...

insert into tblFindIndexQueue select [Action], [Cascade], [EnableLanguageFilter], [Item], [Language], [TimeStamp] FROM [VW_EPiServer.Find.Cms.IndexingQueueReference]

...to this:

INSERT INTO tblFindIndexQueue 
([Action], [Cascade], [EnableLanguageFilter], [Item], [Language], [TimeStamp])
SELECT [Action], [Cascade], [EnableLanguageFilter], [Item], [Language], [TimeStamp] 
FROM [VW_EPiServer.Find.Cms.IndexingQueueReference]
#171508 Edited, Nov 08, 2016 21:55
  • Jouni Huttunen
    Member since: 2010
     

    Yes!

    #171510 Nov 08, 2016 23:40
  • Patrik Andersson
    Member since: 2015
     

    Today I updated the Episerver.CMS to version 10.0.1.0 and with it of course Episerver.Find to latest version 12.2.8.0. After restarting it's like you describe it, "Column name or number of supplied values does not match table definition.

    #171547 Nov 10, 2016 11:43
  • Stephan Lonntorp
    Member since: 2004
     

    Yep, I get the same error. A bug has been reported, FIND-1303 regarding this. 

    Maybe we'll see a session on unit tests, integration tests and installation tests during next year's Ascend Conference :)

    #171556 Nov 10, 2016 17:04
  •  

    We are working on this, and expect a fix to be out on Monday.

    #171565 Nov 11, 2016 8:34
  •  

    Any news on this? I just hit this bug. And it is Monday. :D

    EDIT: Fix was released while I was upgrading. Everything works now.

    #171645 Edited, Nov 14, 2016 15:02