Using FIND for the Internal CMS File Search

Vote:
 

Hi All.

We are using FIND on one of our sites and also have it setup to work as the internal CMS search for both pages and blocks on the site.  However it doesn't work for the file search in the assets pane.  Where the following error is returned when you do a search:

Cannot perform this operation when EPiServer.Search is not set as active in configuration"

Now I assume the above error is displayed because we have disabled the default episerver indexing service however is it possible to use the FIND indexer instead for this search?

I have disabled all the default indexers in the Search Configuration so only the below are enabled:

  • Find files
  • Find pages
  • Find blocks

However I am yet to get it to work?

I don't want to have to re-enable the default EPiServer indexing service just for this functionality if I don't have too, so would appreciate any information or help if anyone has come across this issue before?

Kind regards,

Dave.

#86790
May 30, 2014 16:47
Vote:
 

Hi,

Are files indexed at all?

We have disabled EPiServer Search and solely rely on Find, and that works great.

#86794
May 30, 2014 23:56
Vote:
 

Thanks for the response Johan.

Yes we are indexing the files and they are returned fine in the sites front end, just not from the file search in edit mode.  I have received a response from support to say it is possible in 7.5 but not in previous versions (we're using 7.1 currently).

I assume you are using 7.5?

#86795
May 31, 2014 19:25
Vote:
 

I can confirm that file search inside the Media folder is working (using EPiServer Find) in version 7.5

#89806
Aug 26, 2014 13:41