Value cannot be null after update 7.6

Vote:
 

I recently updated to EPiServer 7.6 and wanted to try out EpiServer Find.

While installing and putting the information in web.config I compiled (works fine) and started my project.

I got in to EPiServer CMS but when trying to access the Find section I get this error: 

Parser Error Message: Value cannot be null.

 

Line 1:  <%@ Master Language="C#" MasterPageFile="~/EPiServerFindEmbeddedResources/EPiServer.Find.Framework.dll/EPiServer.Find.Framework.UI.Views.Shared.Modul
any ideas on why this is keep occuring?
//Alexander

 

#83078
Mar 25, 2014 14:10
Vote:
 

I'm getting the same error. Could it be related to http://world.episerver.com/Modules/Forum/Pages/thread.aspx?id=82638&pageIndex=1 

I'm also getting errors in code(but they do compile). As an example the x in x.RelesWithReadAcces is underlined with red and the text "Cannot convert instance argument type 'namespace.FactPage' to 'EPiServer.Security.IContentSecurable'

var allResults = SearchClient.Instance.Search<FactPage>().For(searchString)
.Filter(x => x.RolesWithReadAccess().Match("Everyone"))
.Select(x => new SearchHit
{

#83081
Mar 25, 2014 15:02
Vote:
 

I have the same problem. I'm not getting any errors from code and everything else works just fine.

Edit: And I just upgraded from 7.1.2 where everything was working with Find also.

#83128
Edited, Mar 26, 2014 11:41
Vote:
 

We have just released a fix for this bug.

It is available for Download in the Nuget feed now.

 

#83137
Mar 26, 2014 13:12
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.