All Find queries fail after upgrade

Vote:
 

After deploying upgraded site to production server I can see that all Find searches gives error:

System.MissingMethodException: Method not found: 'System.Collections.Generic.IEnumerator`1<Newtonsoft.Json.Linq.JToken> Newtonsoft.Json.Linq.JArray.GetEnumerator()'.
   at EPiServer.Find.ProjectionHelper.GetFieldValues(SearchRequestBody requestBody, SearchHit`1 searchHit)
   at EPiServer.Find.ProjectionHelper.GetMappedSearchResultItem[TResult](SearchRequestBody requestBody, SearchHit`1 searchHit)
   at EPiServer.Find.ProjectionHelper.GetMappedResult[TResult](SearchRequestBody requestBody, SearchResults`1 jsonResult)
   at EPiServer.Find.SearchExtensions.GetProjectedResult[TResult](ISearch`1 search, SearchContext context)
   at EPiServer.Find.SearchExtensions.GetResult[TResult](ISearch`1 search)
   at EPiServer.Find.Cms.SearchRequestExtensions.GetPagesResult[TPageData](ITypeSearch`1 search, LanguageSelector languageSelector)

    

The same code is working fine on local machine and on test server. I have tried re-indexing the site without no effect.

I'm running the latest EPiServer and EPiServer Find version (7.6).

#82501
Mar 13, 2014 16:28
Vote:
 

The solution:

  • Make sure you run the latest EPiServer Find version
  • Remove Newtonsoft.Json from C:\Windows\Microsoft.NET\assembly\GAC_MSIL\

Thanks to Henrik Lindström for pointing me in the right direction!

#82503
Edited, Mar 13, 2014 17:14
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.