Tracking scripts not added to the page.

Member since: 2007

Hi,

I have added the webcontrols to my masterpage (in head and before end body):

<EPiServer:RequiredClientResources RenderingArea="Header" ID="RequiredResourcesHeader" runat="server" />

<EPiServer:RequiredClientResources RenderingArea="Footer" ID="RequiredResourcesFooter" runat="server" />

I'm inheriting from TemplatePage<T> and have also added Track() to my query. What am I missing?

var service = ServiceLocator.Current.GetInstance<IClientResourceService>();
var a = service.GetRequiredResources("Header");
var b = service.GetRequiredResources("Footer");

Gives me nothing...

#113423 Nov 20, 2014 2:59
  • Member since: 2007

    The tracking tags are added to all hits' URL. It's just the scripts that are missing.

    #113424 Nov 20, 2014 3:01
  • Member since: 2009

    Hi Johan!

    I think you are testing in Internet Explorer? IE has a function called "Do Not Track" that is as default set to true. If you want to test if that's the problem, then in IE click on the cog wheel in your upper right corner, then click on "Safety" -> "Turn off Do Not Track requests". 

    #114112 Dec 04, 2014 15:08
  • Member since: 2007

    Yep I did and your are correct! I was really scratching my head here. This should be mentioned in the documentation, or maybe it already is? Thanks!

    #114133 Dec 04, 2014 18:06
  • Member since: 2007

    I'm trying to mark your comment as answer. But nothing happens :( Thanks anyway.

    #114134 Dec 04, 2014 18:08