The 'ShouldIndex' function could not be evaluated for Page: 358. Can't load property type

Vote:
 

Hi,We are using EPiServer CMS 6 R2.

Recently we have createda custom property which is a listbox.

Everything is working fine in development environment, but when we moved the code to Test environment we are seeing an Error message while running the EPiServer Find CMS Indexing Job.

The Error message says:

Indexing job [unknown] [Page]: An error occured while filtering Page: 358. The 'ShouldIndex' function could not be evaluated for Page: 358. Can't load property type 'EPiServer.TRW.CustomProperty.SignPostListBox, EPiServer.Templates.Public'

We are wondering when the same code is working in dev environment why it is not working in Test environment.

 

Can somebody please help me to solve this issue.

Thanks.

#75370
Sep 26, 2013 12:10
Vote:
 

Does Test and Dev environment use the same database or are those separate?

#75375
Sep 26, 2013 13:15
Vote:
 

Hi,

Dev and Test environments are using seperate databases.

#75380
Sep 26, 2013 13:34
Vote:
 

If you navigate to admin/config/property configuration and "Edit custom property types" --> can you verify that the property in question is not registered in EPiServer several times, and that the type is correct.

#75383
Sep 26, 2013 13:40
Vote:
 

Hi,

I checked it and confirming that it is registered only once with the same name as we specified in dev.

Is ther any other check that I'm missing here?

Thanks.

#75474
Sep 26, 2013 14:44
Vote:
 

Are there any more detailed error in the episerver log file? It's usually saves the stacktrace there

#77534
Nov 20, 2013 18:12