Sort order not affecting new page

Vote:
 

Hi!

I have a node that has "sort subpages" set to to "Start publish date (latest first)". If I publish a new page under this node, it goes to the bottom instead to the top. I have to change the sort order for the node to something else, and then back to start publish date, for the new node to appear at the top.

Is this a bug in Episerver?

#207783
Edited, Oct 03, 2019 16:55
Vote:
 

What version of Episerver are you using?

With the latest version, this is how it works for me:

  • Click «create page», fill in required properties.
  • The page is saved and displayed at the bottom of the list.
  • Publish the page.
  • The page is now moved to the top of the list.

If you schedule the page for being published in the future, I guess it will move to the top of the list when it's published.

#207791
Edited, Oct 03, 2019 11:11
Vote:
 

Aha, I see this the behavior in a newer version too. The version of the problem site is 10.10.

In 11.12 it works as you describe. So I guess the solution is to upgrade. Thanks!

#207792
Oct 03, 2019 11:16
Tomas Hensrud Gulla - Oct 03, 2019 11:52
Excellent!
Vote:
 

So I've upgraded the site, but the problem still exists. It's now version 11.12. Sometimes it appears at the top when I publish, but sometimes it doesn't. It's quite unstable.

What could cause this? If I set sord order to "According to creation date", it always appears at the top, because it is placed there immediately when it's created. So it looks like it's the event that should put it at the top when I publish that isn't always triggered. 

#208463
Edited, Oct 24, 2019 14:37
Vote:
 

Hi,

Is there anything in the log file related to this?

#208474
Oct 24, 2019 15:58
Vote:
 

Hi Torunn,

First of all, when you create a page the created date is immediately updates (even you haven't published it). That's why you see immediate effect.

But, when you publish that page, the publish date is updated. So at that time page is moved to top.

Now, in your case. If you change the publish date manually, after that even you publish the page the publish date will not change. So you can verify that when you publish the page the published date field is updating or not (in settings tab) for the page that not appearing at top?

If it's not appearing then, you need to manually empty that field (published date). Publish now and it will work.

#208500
Oct 25, 2019 4:27
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.