Required nuget-package Microsoft.Tpl.Dataflow doesn't exist anymore.

Vote:
 

The current latest version of EPiServer.CMS.Core (11.9.4) has a dependency on a Nuget package that doesn't exist anymore.

https://www.nuget.org/packages/Microsoft.Tpl.Dataflow/4.5.24

I can only assume it's been recently delisted and hopefully the next release of EPi won't reference it? From what I can see:

https://www.nuget.org/packages/System.Threading.Tasks.Dataflow/

...may be what should be used from now on?

Am I correct, and there will be an update soon? If not. How am I to solve this issue? I can't install my packages at the moment.

I am targeting .NET 4.6.1

//Martin

#196428
Aug 30, 2018 12:16
Vote:
 

We used Microsoft.Tpl.Dataflow since there was no NET45 kompilation in the other one but that seems to be adressed, anyhow, we will re-publish that in our feed until we get this sorted.

#196431
Aug 30, 2018 15:15
Vote:
 

You will only get the error message if you use Package Manager Console. If you use Package Manager GUI to update packages then it does not complain about Microsoft's missing TPL package.

I've just tried Update-Package again in the Console with both Alloy (MVC) and Empty projects and I still get a missing TPL package error unless I use the GUI to update packages.

I am using Visual Studio 2017 version 15.8.2. Versions of Visual Studio 2017 before 15.8 did not have this problem.

#196452
Edited, Aug 31, 2018 8:20
Vote:
 

Thank you all. I'm looking forward to EPi updating to use the now 4.6.1 supported System.Threading.Tasks.Dataflow package. But in the meantime. Thank you Mark for your work around. I do indeed use the latest version of VS2017 and my problem may have started after an update.

EPiServer.Find.Framework 13.0.1 has the same issue by the way. Does that need to be reported somewhere else?

#196454
Aug 31, 2018 9:01
Vote:
 

There is a discussion on the .NET FX repo about this behaviour as well: https://github.com/dotnet/corefx/issues/24547

Edit: A bit more complex that I initially realized since that new package have no "real" .NET 4.5 compilation so not easy for us to switch, we would require .NET 4.7.2 which have improved .NET Standard 2 support, we will investigate this further...

Bug report: https://world.episerver.com/support/Bug-list/bug/CMS-11610

#196459
Edited, Aug 31, 2018 10:30