Error in TinyMCE for users in MVC view

Vote:
 

Have tried to add TinyMCE to a MVC view so that users who are not editors can use the enhanced editor.

When clicking on the epilink-button I get the following error:

  1. Uncaught TypeError: Object #<Object> has no method 'CreateDialog' editor_plugin.js:1
    1. (anonymous function) editor_plugin.js:1
    2. o.create.execCommand tiny_mce.js:1
    3. i.onclick tiny_mce.js:1
    4. (anonymous function) tiny_mce.js:1
    5. p

 

I have followed the following examples and updated them for EPi 7:

http://world.episerver.com/Documentation/Items/Tech-Notes/EPiServer-CMS-6/EPiServer-CMS-6-R2/TinyMCE-Developers-Guide3/

http://world.episerver.com/Documentation/Items/Tech-Notes/EPiServer-CMS-6/EPiServer-CMS-6-R2/TinyMCE-Developers-Guide/

These are the referenced files in my view:

<script type="text/javascript" src="/public/Shell/ClientResources/EPiJQuery.js"></script>
<script type="text/javascript" src="/Util/Editor/tinymce/tiny_mce.js" ></script>
<script src="/Util/javascript/EPiServerScriptManager.js" type="text/javascript"></script>
<script src="/Util/javascript/system.js" type="text/javascript"></script>
<script src="/Util/javascript/system.aspx" type="text/javascript"></script>
<script>
tinyMCE.init({
theme: "advanced",
mode : "specific_textareas",
editor_selector : "mceEditor",
skin: "epi-light",
plugins: "wordcount,epiexternaltoolbar,epilink",
theme_advanced_toolbar_location: "top",
theme_advanced_toolbar_align: "left",
theme_advanced_statusbar_location: "bottom",
theme_advanced_buttons1: "link,epilink",
theme_advanced_buttons2: "",
theme_advanced_buttons3: "",
theme_advanced_resizing: true
});
</script>

#69758
Apr 04, 2013 18:14
Vote:
 

Have you found a solution for this? I have the same problem.

#71511
May 21, 2013 13:57
Vote:
 

If you are want to use an editor on a public template I would really download a separate version of TinyMCE and put that in your templates. The version that has been used for the UI and available for templates will be obsoleted once we drop the legacy UI in a future release.

#71518
May 21, 2013 15:15