XForms column is not loaded/saved

Vote:
 

Hello,

I haven't worked much with XForm so I'm a little clueless on what could be happening in this CMS 6 R2 project we're working on.
We have a form page that displays different forms that the editor can select in edit mode. When the user fills in his data an email is sent to the email address he provides.  The emails are sent/receivd without problem, however the email address is not displayed at all in "Formulärdata" on edit mode, the column is displayed as empty. My first thought was the there could be some problem in the code since we suscribe to the BeforeSubmitPostedData event,  but then i tried with a different form and all columns are displayed correctly. So the problem seems to be with this particular one. I have looked at the form definition and compared the one that i know for sure works, but still can't find any relevant differences.

Where else can I look to track down the issue? How can i know if the problem has to do more with the saving or the loading of the field?

Thanks so much in advance,

/Kenia

#59720
Jun 25, 2012 11:38
Vote:
 

I don't know the reason why but you can hook up the BeforeSubmitPostedData event and check the XFormControl.Data-object to see if you email field is there. Then you should get an idea where to start looking...

#59782
Jun 27, 2012 16:24
Vote:
 

Have you tried recreating the email address field and renaming it something else?

#59866
Jul 03, 2012 8:58
Vote:
 

Hello guys, and thanks for your replies.

Unfortunately none of the above worked, the email value seems to be saved correctly on the XFormControl.Data but still it's not displayed, really weird. Recreating the email field though is not possible, because this form is used in serveral pages on the site, so we can't really make such a test.

#60250
Jul 30, 2012 12:10
Vote:
 

How does that particular Xform view looks like in the database? The email field is something every XForm should have, so maybe you have two email fields; one that is the system email field and one that is the custom email field.

Is this site upgraded or is it a new project?

#60251
Jul 30, 2012 12:25