Change url to edit mode

Vote:
 

Hi!

Is there an easy way to change the url to edit mode? We have different sites and with different paths to edit mode in Epi
/cms/cms/edit
/secret/secret/cms/cms
etc

Is there an easy way to just change them? Thank you very much.

#52509
Aug 01, 2011 10:15
Vote:
 

The following article talks about securing edit and admin mode but it also shows you how to changed the edit/admin mode URL:

http://world.episerver.com/Documentation/Items/Tech-Notes/EPiServer-CMS-6/EPiServer-CMS-60/Securing-Edit-and-Admin/

 

#52515
Aug 01, 2011 12:55
Vote:
 

Hi!

Thank you very much for the reply. Ehm, I'am sort of a newbie developer, and I dont fully understand that article (I have read it before posting here). Can you break it down?

I'am eger to learn, but in this case, because of other things that needs to get done, I just look for the simplest possible way to change the url that editors use to access Epi cms.

Where do I change it? I did a search in explorer on the server for cms/cms/edit but got no result, I did a search in the project folder "search for a phrase in a file"

Thanks alot for the help

#52516
Aug 01, 2011 13:08
Vote:
 

Is it enough to just change in <siteSettings ALOT of attributes uiUrl="xxxxx" /> in web.config? It seems to omit "edit" in the path, why?

#52517
Aug 01, 2011 13:29
Vote:
 

The set path is used as base path for both edit, admin and the dashboard. The folder structure below /sec/ui etc is the real physical structure of the files in the episerver installation which is always the same (in the same version), that's why you don't need to specify /sec/UI/cms/edit etc.

#52519
Aug 01, 2011 13:52
Vote:
 

I dont understand, sorry. I will take courses to learn more about these things.

But, the critical thing is to change the url for our editors. Is it enough to change <siteSettings uiUrl="xxxxx"> to "yyyyyyy"? Nothing else needs to be done?

#52520
Aug 01, 2011 14:07
Vote:
 

As described in the article David linked you also have to change the VPP and the location paths (the location for admin is generally set up to allow other groups than the rest of the UI which is why there is (generally) a location for admin but not for edit (the latter inherits the "main" UI path's permissions)).

#52521
Aug 01, 2011 14:35
Vote:
 

I dont understand, sorry.

We have a site, the editors use domain/secret/CMS/edit/ to enter edit mode in Epi. I want to change this to domain/secure/edit. How do I do it? The site is running on Epi Server 6.

The guide says "Change the uiUrl attribute of the siteSettings element in the web.config file." but there is no such tag in web.config, however it is one in EpiServer.config, it has an attribute with a value like this: uiUrl="~/secret/CMS/". It makes sense, but Iam just wondering why the "edit" part is ommited? But more importantly, if I change the value to "~/secure/", is that one step in the right direction? If so, what is the next step?

How many more steps are there? Do I have to do the same steps to change this for admins? Some strange things in web.config, like <protectedModules rootPath="~/secret/"> has something to do with this?

Can you break it down to simple steps and point to what tag/attribute/value to change and in what files. And also, do I have to move any files or folders?

Thank you!

#52532
Aug 02, 2011 8:29
Vote:
 

You can't remove the "CMS" part of the path in CMS 6 by using the settings. This extra level of depth was added in v. 6 to allow for other products (episerver, 3rd party or custom) to use online center as the top level navigation. So edit will always be /whatever/CMS/edit.

#52543
Aug 02, 2011 9:38
Vote:
 

Ok I understad. But what if I want to change it to domain/secure/CMS/edit?

#52547
Aug 02, 2011 10:47
Vote:
 

Then just change your current values reading secret/CMS/ to secure/ in the uiUrl, VPP, locations and protectedModules and you should be fine.

#52548
Aug 02, 2011 11:09
Vote:
 

Oh, and the thing I always forget: You have to go into admin mode - page types and change the page template URL for the root page and the recycle bin because those values are stored in the database.

#52549
Aug 02, 2011 11:19
Vote:
 

Can you specify a bit more? Do I find all this in episerver.config? If so, can you point me to tags and attributes.

Many thanks

#52550
Aug 02, 2011 11:24
Vote:
 

Lets go over it again. We have a site,
the path to edit mode is domain/secret/cms/edit
i want to change this to domain/secure/cms/edit

What should I change and where? Can you be more specific? Can someone fill in the blanks below?


uiUrl = an attribute in <siteSettings/> tag in episerver.config
VPP = what is it and where?
Locations = what is it and where?
protectedModules = what is it and where?

 

Root Page in Admin mode = SysRoot? filnamn = /EPiServer/CMS/edit/workspace.aspx - the path doesnt seem logic (where is 'secret'?), what do I change it to?

Recycle bin in Admin mode = SysRecycleBin? filnamn  = /EPiServer/CMS/edit/WastebasketPage.aspx - the path doesnt seem logic (where is 'secret'?), what do I change it to?

 

in episerver.config, what is this?
<add name="UI" virtualPath="~/secret/CMS/"
<add name="EPiServerCMS" virtualPath="~/secret/CMS"

#52560
Edited, Aug 03, 2011 7:55
Vote:
 

VPP = Virtual Path Provider = the virtualpath/providers element in the episerver section / episerver.config. It's the elements you mention last.

By locations I mean the ordinary asp.net location elements in web.config used to add specific configuration for parts of the application. In this context they are used to secure different parts of the episerver UI by blocking access to all users except some (like WebAdmins to the admin path). You have several elements <location path='/secret... that you have to change. They are in web.config.

There is also an element protectedmodules in web.config (section episerver.shell) with a rootPath attribute you need to change.

SysRoot and SysRecycleBin, yes. A bit strange though that you have those paths, the recycle bin and root page can't be working in the current state either (if you click the recycle bin for example you probably get a 404 error in the edit panel). It seems you have some default values and that they were not changed by deployment center when you selected your original UI url. Nevermind, you just have to change the file names to /secure/cms/edit/workspace.aspx etc to make them work after you change the VPP configuration, or to /secret/cms/edit/workspace.aspx to make them work in your current setup.

 

 

#52562
Aug 03, 2011 8:38
Vote:
 

Thank you very much. I think Iam on my way. I can now login in with domain/secure/CMS/edit, so it worked. But the layout in Epi CMS looks a bit strange now, the top part seems like it has no formating it is just plain text and default blue links. Is it something I missed?

Should I change this to 'secure'?
<add name="EPiServerShell" virtualPath="~/secret/Shell"

#52566
Edited, Aug 03, 2011 12:37
Vote:
 

Yes, change that too. It sounds like there is some stylesheet it can't load. So if changing that doesn't help, see if you can find any other "/secret" strings in the configs that you can try to change.

#52567
Aug 03, 2011 13:22
Vote:
 

<siteSettings uiEditorCssPaths=""> has a value - but that only affects the styles for editors to use with the xhtml editor box, yes?
What else can it be, css related?

And, I did a search for 'secret' in both web and episerver config, no results. And I have checked also.

#52568
Edited, Aug 03, 2011 13:45
Vote:
 

No, it's not the editor CSS:es. I suggest you use Firebug or Fiddler to see if a CSS fails to load and in that case which path it is looking for and what error code you get.

#52590
Aug 04, 2011 8:01
Vote:
 

Ok thanks. Can I just ask something? :) In your opinion, is this an easy piece of cake thing to do? Or is it as complicated as I think it is and error prone? Is this something people do after deployment?

Thanks for all the help and patience!!!

#52605
Edited, Aug 04, 2011 15:57
Vote:
 

I'd say changing the UI path is fairly easy and has probably been done in many projects, but probably not after deployment. I mean it could be done in some service window while a new version is deployed etc, but not outside of a service window.

#52637
Aug 08, 2011 9:19
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.