EPiServer.Security namespace

Vote:
 

I am unable to get EPiServer.Security.AccessLevel enum? Actually i want to use GetPage to get contents of the page. Getpage has three parameters, last parameter is  EPiServer.Security.AccessLevel but AccessLevel enum is not coming. Any idea?

#55184
Nov 21, 2011 18:56
Vote:
 

The overload of GetPage which accepts an AccessLevel parameter is obsolete since CMS 5 R2 and the parameter will be ignored anyway. GetPage will return any page, you have to check the PageData.ACL (.QueryDistinctAccess for example). You'll still need the AccessLevel enum though, and your problem is probably that you don't have a reference to the EPiServer.BaseLibrary assembly.

Good luck!

#55186
Edited, Nov 21, 2011 19:22
Vote:
 

Thanks for your reply. Yes, you are right, reference to EPiServer.BaseLibrary was missing. Problem solved!

#55195
Nov 22, 2011 12:32
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.