Disabling caching for debug

Vote:
 

Hi,

This may be quite a simple question, but it's baffled me!

I've deployed our application to a test server quite a few times, and sometimes I get an error when deploying it. Usually the error is saying how a file your aspx is referencing isn't there, and so forth.

Trouble is, it then caches that page (seemingly) and even though I re-copy the files across, it doesn't always fix the problem.

Also, sometimes I find that copying my changes up to the server can take anywhere up to an hour to update. Is this due to the sites tag in the web.config setting caching settings that I need to disable? 

Is there anything I can do to switch off caching entirely until the project's ready to go live to the public? 

Thanks for any help!

Karl. 

#32216
Aug 26, 2009 10:45
Vote:
 
You could try deleting the ASP.NET Temporary files... It usually helps whit this type of scenario
#32231
Aug 26, 2009 14:06
Vote:
 

I'll give that a shot next time we have problems.

Is that the temp files folder within c:\program files\microsoft\asp.net.......\?

Thanks for the advice,

Karl. 

#32232
Aug 26, 2009 14:56
Vote:
 
the path for this folder would be C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files or  C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files depending on your environment 
#32233
Aug 26, 2009 15:01
Vote:
 
Ah that's great, thanks Lars!
#32280
Aug 28, 2009 17:08