EPiServer search ignore special characters

Vote:
 

Hi,

EPiServer search feature ignores searching special characters like %, @, & etc. I have created content with these special characters in different pages. If my search query is "_", episerver returns all the results. This is a strange behaviour as I believe all search engines should return the results of our search query provided it is available.

Request you all to provide some answers for this query.

Thanks,

Siva

#25876
Nov 11, 2008 7:37
Vote:
 

Which search function are you talking about, free text search or FindPageWithCriteria ?

 

#25879
Nov 11, 2008 9:01
Vote:
 

Hi,

I am using free test search. I am using the following code to perform search on the contents.

<EPiServer:SearchDataSource ID="SearchDataSource" runat="server" EnableVisibleInMenu="true">

<SelectParameters>

<EPiServer:PropertyParameter Name="PageLink" PropertyName="SearchRoot" />

<asp:controlparameter name="SearchQuery" controlid="SearchText" propertyname="Text" />

</SelectParameters>

<Criteria>

<EPiServer:PropertyCriteriaControl ID="PropertyCriteriaControl1" Name="RemoveFromSearch"

Condition="NotEqual" runat="server" Type="Boolean" Value="True">

</EPiServer:PropertyCriteriaControl>

</Criteria>

</EPiServer:SearchDataSource>

#25897
Nov 11, 2008 13:18
Vote:
 

If you wan't to change the free text indexing you need to change the regular expression that we use for indexing content into words. Its defined in web.config as "indexingTextRegExp". Its kind of complex so you need some kind of debugging tool for regular expressions so that you can test it.

 

#25904
Nov 11, 2008 15:35
Vote:
 
Many thanks. I will test this and get back to you.
#25934
Nov 13, 2008 7:52