Problem with impersonate

Vote:
 
I want to use impersonation on a web site so I add the tag in the web.config. The problem is that in edit mode the editor toolbar disappears. Does anyone know why? We use EPiServer 4.41 on this site. Best regards, Isabel
#13147
Mar 25, 2008 18:35
Vote:
 
I'm not sure what the problem might be, but am more interested in why you need to use Identity impersonation?
#15466
Mar 25, 2008 18:47
Vote:
 
I want to add a folder on the file server (not the same server as the web) as an upload folder in episerver. I use the unified file system to add the folder and manage it with episervers file manager. When I turn on impersonation, it works fine, I can open the folder on the external file server in episervers file manager, but then the edit mode is not working correctly. When I run without impersonation, I guess it is the web servers aspnet-account that tries to access the folder on the file server and that account has no access to it, so I get an access denied error. Any suggestions on how to solve this?
#15467
Mar 25, 2008 18:47
Vote:
 
Have you checked that the user accounts you are impersonating have read access to all the folders and files in the website? I would try resetting the permissions on the file system in the edit/admin/util directories to make sure your website users can read the files. The other thing is to make sure you are using Windows Authentication and Integrated security in IIS. Just some suggestions...
#15468
Mar 25, 2008 18:47
Vote:
 
Thanks for your suggestions. My user has read access to all folders and files and I use Integrated Windows authentication in my IIS. Still doesn´t work. There´s something strange, and I can´t see why. If I add username and password for my account in the impersonate tag it works but not if I only set impersonate to true.
#15469
Mar 25, 2008 18:47
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.