action window plugin in .net 2.0

Vote:
 
Hi All I did an episerver site last year in 1.1, and got action window plugins working fine. Having no joy with 2.0 though... i can't see what I'm doing wrong. I have a page called ActionWindowUserDownload.ascx, with a codefile of ActionWindowUserDownload.ascx.cs ActionWindowUserDownload.aspx contains: <%@ control language="C#" autoeventwireup="false" codefile="ActionWindowUserDownload.ascx.cs" inherits="development.ActionWindowUserDownload" %> Hello there ActionWindowUserDownload.ascx.cs contains: using System; using System.Data; using System.Configuration; using System.Collections; using System.Web; using System.Web.Security; using System.Web.UI; using System.Web.UI.WebControls; using System.Web.UI.WebControls.WebParts; using System.Web.UI.HtmlControls; using EPiServer; namespace development { [EPiServer.PlugIn.GuiPlugIn(DisplayName = "ActionWindowUserDownload", Description = "Action window user download plug-in", Area = EPiServer.PlugIn.PlugInArea.ActionWindow, Url = "~/ActionWindowUserDownload.ascx")] public partial class ActionWindowUserDownload : System.Web.UI.UserControl { protected void Page_Load(object sender, EventArgs e) { } } } I've recompiled till I'm blue in the face, tried various namespaces etc... but the new option never appears in the action window. Does anyone know what might cause this? Thanks in advance, Dan
#13092
Mar 25, 2008 18:35
Vote:
 
Well i tried doing a similar test using the "simple plug-in for action window" tutorial in the documentation. ( http://www.episerver.com/downloads/Documents/the_book/13_Extending_EPiServer.pdf ) And it worked like a charm in 2.0. But I cannot see anything in your code that is any different. Atleast not that could cause it not showing up. Are you sure you dont get any hidden compile errors or something? Your code should realy work
#15407
Mar 25, 2008 18:47
Vote:
 
Hi Dan! Your code *should* work. Make sure that your compiled dll really ends up in the /bin folder. Do other plugins load and work properly? Do you get any errors when requesting the first page when site has been restarted? Regards, Johan Olofsson
#15408
Mar 25, 2008 18:47
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.