trouble moving/distributing site

Vote:
 
I have a EPiServer solution that i need to move to another location, previosly located in root-folder. Now i need to move the site to another location, but I cant find any instructions on how to distribute/install/copy a solution to a new place. When I try to move the web page, I get the message "The current template does not match the specified page type file" However, I can access the admin/edit-pages. The errormessage appear even if the default-page doesn't contain any controls or episerver properties. Any Idèa? //"The current template does not match the specified page type file "
#12940
Mar 25, 2008 18:35
Vote:
 
Do you want to move the site to a subfolder or to another root site on another server ? The message means that you are trying to load a page with another template than the template this page was ment for. F.ex. you have a normal webpage with id=100. This is loaded with [rootsite]/templates/page.aspx?id=100. If you try to load this page with another template like this [rootsite]/templates/form.aspx?id=100 you will get the error. /Øyvind
#15124
Mar 25, 2008 18:46
Vote:
 
Accually, the problem appeared even though the pages and db where the same. I had not made any changes, besides that the site where moved to a published sub directory (previously the root-dir). Lucky, I found that one other person had had the same problem. public override void ValidatePageTemplate() { } This override solved the problem, but I really don't know why. The site workes fine without any other changes, so I don't understand why I get an error if I don't override this method.
#15125
Mar 25, 2008 18:46
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.