FriendlyUrl problem - not appropriated url structure

Vote:
 
Hi, I was working on enabling friendlyUrl functionality on 'old' solution. I'll cover here what problem I encountered and how it was solved. First of all I added required code: To web.config 1. 2. As well as to header.ascx: 1. After that friendlyUrls were not working like I suppose them to. After some investigations and Steve C. help, it appeared that url structure was a previous attempted on making search engine friendly urls. Example url was: http://www.somepage.com/templates/Page____141.aspx and should be: http://www.somepage.com/templates/Page.aspx?id=141 To solve it follow those steps: 1. Change back to the "interactive use" type of urls as shown in screenshot below. http://psendor.pl/episerver/friendlyurl/friendlyurl1.jpg 2. Then "Rebuild" all addresses. This will update all the urls to all pages in the database. Keep the settings as shown below. http://psendor.pl/episerver/friendlyurl/friendlyurl2.jpg After done this, whenever you surf to a page on the site, it should show the urls in the "page.aspx?id=1234" style. Then, try to turn on the friendly urls again (on Manage Web Addresses), and see if it works.
#12907
Mar 25, 2008 18:35
Vote:
 
Wow, it worked! I wish I had searched here for a solution to this problem _before_ spending a couple of hours trying to solve it... :) Thanks! /Patrik
#15078
Mar 25, 2008 18:46
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.