Configuring the Cache in Multi-server Scenatios

Vote:
 
Hi, I have 2 Episerver sites (same code), one on my local machine (XP) and one on a server (Win2000). If I update a page on my local machine, I want the cache to be invalidated on the Win2000 server. I've used the "Configuring the Cache in Multi-server Scenatios.pdf" document to setup the remote web sites. In the end there are 2 remote sites (my localhost and the Win2000 server). I've configured the web.config (EPsLocalSite,EPsCacheListeners) and made sure that the "Shared secret for signature" are the same. But when pressing "Ping" label, I get the following error: An error occured while talking to "zasrvdev3(http://zasrvdev3:8080/WebServices/DataFactoryService.asmx)": Communication was signed but checksum was not valid The same happens when I press the other "Ping" label as well. Any ideas how I can get pass this or what I'm doing wrong? Thanks! Danie
#12895
Mar 25, 2008 18:35
Vote:
 
Just a hunch, the remote web sites data is cached, and I believe there was (and might still be) a bug where the cached data is not flushed when these settings are saved. Make sure the values ar correct, casing and all, and do an iisreset before you test it again. /Steve
#15056
Mar 25, 2008 18:46
Vote:
 
Also, you could try to enable logging, and look for 1.7.x messages. See http://www.episerver.com/downloads/Documents/TechNotes/EPiServer%204.61/3.%20Logging%20&%20Log%20Service/Logging%20in%20EPiServer.pdf for more information. /Steve
#15057
Mar 25, 2008 18:46
Vote:
 
This error sounds like a type error in the signature key. But just a thought: You say "In the end there are 2 remote sites". Shouldn't you have 3 Remote Sites, one for www.domain.com, and then two others (www.domain1.com and www.domain2.com)? Frank
#15058
Mar 25, 2008 18:46
Vote:
 
Hi, I've tried an iisreset, but without luck. I'll check what messages the log4net generates. The example in the document did mentioned that there should be 3 sites. I'm not sure what the 3rd site should be... The 2 remote sites that I've configured refers to the site running on my XP development machine and the other one on the Win2000 box (this is just for testing purposes). Thanks! Danie
#15059
Mar 25, 2008 18:46
Vote:
 
If you want to invalidate cache between two servers, you'll need three sites under Remote Web Sites in admin. From the top off my head: 1. Both sites need to have the exact same "local site name" (which is the EPsLocalSiteName setting in web.config. 2. Add one remote web site, give it the same name as the value in the EPsLocalSiteName setting. This is where you create the shared secret code (copy it to notepad for later use). Leave the other fields empty (no url, username or password) 3. Add one remote site for server 1 (I'll name it server1 here). Paste the shared secret. Url would be something like http://server1/ and add the username and password. If you have local server users (same username and password on both servers) leave domain empty. 4. Add one remote site for server 2 (I'll name it server2). Same shared secret. Url would typically be http://server2/ and username and password. 5. In web.config on server1, change EPsCacheListeners to "server2" 6. In web.config on server2, change EPsCacheListeners to "server1" You should now be able to ping the other server, from each side. Make sure you test it. Giving access to the WebServices directory is described in the whitepaper, as far as I can remember. The reason the local site names have to be the same on both servers, and you need the "empty" remote web site is for EPiServer to generate the same cache invalidate message independent on which server it is called from. It is not intuitive - by far - but it works (when configured correctly). /Steve
#15060
Mar 25, 2008 18:46
Vote:
 
Just a short comment: We once failed because the names in web.config were in wrong case. Check that the name given in the admin is EXACTLY the same as in web.config. Good luck! /Christian
#15061
Mar 25, 2008 18:46
Vote:
 
Hi, thanks for your help, I can finally start pinging the sites. The problem was with the 3rd site (www.domain.com) which didn't have the same name as the site's name in the web.config. Thanks again! Danie
#15062
Mar 25, 2008 18:46
Vote:
 
Hi, one last question: Is it possible to invalidate custom defined cache areas? Thanks! Danie
#15063
Mar 25, 2008 18:46
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.