Globalization issues

Vote:
 
I'm having some issues with the new globalization feature in Episerver. I firstly install episerver without templates and set the EPsLanguage setting to Norwegian... When you then go to "Manage Web Site Languages" in admin mode, you can see "Default - EN" as language of choice. As i want Norwegian -NO to be the default language on my customers site I disable "Default" and then enable "Norwegian"...I also set Norwegian to the "Default language". From this I assume that when the webeditors now start entering information on the site the language should be set to Norwegian right… Then when your customer decides they need to have the site in Danish (or some other language) as well…you then go to the admin mode to enable Globalization and to enable Danish as a language. Logically the site should now have a lot of content already published in Norwegian that needs to be translated into Danish. Well no…The content you would think would have be entered in Norwegian has been entered as Default…and is missing for both Norwegian and Danish…WTF?? Do you have to activate globalization before you start entering content? Is this the only way?? If so where can I get my hands on the sql mentioned here http://www.episerver.com/en/EPiServer_Knowledge_Center/developerforum/EPiServer-Developer-Forums-/1805/8574/ Any comments are welcome
#12768
Mar 25, 2008 18:35
Vote:
 
When enabling the Globalization, you need to set the default language to the correct language before you start entering content. The site needs a master language, which is the default language. When you want to start using danish, you just enable danish and publish pages in this language. If you don't want to use other languages than danish, you use replacement language to always display danish. I'll send you the "convert language for a branch" beta in a email. /Øyvind
#14861
Mar 25, 2008 18:46
Vote:
 
Hmm...The globalization feature is great but a little quirk and not very intuitive to configure. The plugin you sent me saved a lot of time...hope it will be available for everyone one of these days Cheers
#14862
Mar 25, 2008 18:46
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.