Indexing has not been enabled on Documents

Vote:
 
I am trying to enable search on a versioned share in EPiServer 4.61 but I keep getting the error message "Indexing has not been enabled on Documents" when I perform a search in EPiServer. The Indexing service in Windows is running and when I try to query the catalog from within the management console I get hits on documents in my Documents directory (maps to the default "/docrepository"). Searching documents in the upload folder works just fine. This applies to the search template, the workroom template and the EPiServer file manager in Edit and Admin. What am I missing? My catalog in the Indesing service is "SVRupload" and it indexes the upload folder as well as the docrepository folder. In the search template I have the following attribue on the EPiServer:PageSearch control: UnifiedSearchLocations="/upload". In web.config I have the following settings:
#12730
Mar 25, 2008 18:35
Vote:
 
From the Unified File System Tech-note: "Important! If you are using a versioned share...no Index Server configuration is needed as this handler has built-in search capabilities". I think this implies that you CAN'T configure Microsoft Indexing Service for versioned shares, but if you start EPiServer Manager, navigate to your site, choose Capabilities and Disable / Enable Indexing, you should find that the error goes away, and Documents is searchable. (It's not clear in the documentation whether you can have a custom file summary search on a non-versioned share - I suspect not though).
#14796
Mar 25, 2008 18:45
Vote:
 
Thanks for the tip! Now it works just fine. Although I'm not clear on why it wokrs now, I had already disabled and then enabled indexing via EPiServer Manager. I guess you need to do things in a certain order, and I haven't found very much on this subject in the do documentation. Also, custom file summary search appears to work just fine on non-versioned shares.
#14797
Mar 25, 2008 18:45
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.