Applying CSS style sheets in XHTML String property

Vote:
 
When editing an XHTML string property in edit mode, not all styles from the style sheet are being loaded. I have separated my styles into various style sheets using the import command: @import "global_typography.css"; Only the styles in the stylesheet I specify in admin mode in the system settings for the Path to CSS file for the Editor field get loaded. Is there a way of getting the editor to pick up the style sheets from the import commands, or is there another way of getting the correct styles to load in from various style sheets?
#12693
Mar 25, 2008 18:35
Vote:
 
Hello! There is currently no way of specifying several css-files (at least as far as I know) but I just added support for it so that it will be possible in the next release of EPiServer.
#14754
Mar 25, 2008 18:45
Vote:
 
Well there is a way that I have found to add your own stylesheets to the editor and that is to do the following. 1. Enable the EPfEnableAlternateFiles setting in the web.config. 2. Create a folder called Util_ in your website. 3. Take a copy of the EmptyEditor.aspx file from the Util directory and paste it into your new Util_ directory. 4. Edit the new aspx file and add in your stylesheet references (Not sure about imported stylesheets but you can use link tags to specify multiple stylesheets). Also, if you don't want to use the alternate files function you can just edit the EmptyEditor.aspx file in the Util directory, but this is not recommended as it could get overwritten with the next upgrade.
#14755
Mar 25, 2008 18:45
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.