Changing startpage not working, neither is internal shortcuts

Vote:
 
I have just cloned a site at a different location, since parts of the site needed to be moved, this worked out very well. All pages work fine. However, I need to change the startpage for the site to a 'non-startpage' page. After using EPiServer Manager to set the new id for the startpage, and I browse to http://localhost/ -> breakage with template mismatch. I tried to create a new page of type 'Start Page' and then use a internal shortcut to go to the page I would like as a startpage. This works if I browse to the new startpage in edit mode, if I enter http://localhost/ the internal shortcut does not execute and I am kept standing at an 'empty' startpage (this page has no content, just an internal shortcut). If I write the 'full path' (http://localhost/Default.aspx?id=xxx) it does not apply the internal shortcut either, it only works in edit mode. Recap problem: 1) I would like to use another page than a startpage as the front for the website. 2) If the above is not possible, I would like startpages to apply internal shortcuts. Ideas, fixes, solutions welcome.
#12625
Mar 25, 2008 18:35
Vote:
 
Without understanding your question completely, and to just give a feeback on my experience with template mismatch problem for the "start page": When I put the template, that I was going to use as a start page, in the root of the website (as default.aspx) and pointed my new page type to that template - I did not get the template mismatch error any more.
#14621
Mar 25, 2008 18:45
Vote:
 
That solved my problem, thank you.
#14622
Mar 25, 2008 18:45
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.