EPiServer Link Tool

Vote:
 
After version 4.30 is it possible to choose "open in a new window" from the Link Tool when choosing a link to a document or a page? I guess this has to be handled manually today with a user property? /John
#12432
Mar 25, 2008 18:34
Vote:
 
The target option is only available when inserting a link in the Editor. When using the link tool to specify the value of an url property, the only thing available is the url itself. Therefore, you'll have to add a target property in order to specify the target for the url property. Best regards, Sarah Larsson
#14245
Mar 25, 2008 18:44
Vote:
 
I figured as much but then I went ahead and did a test upgrade to 4.51 from 4.30 on my laptop. I saw that it had been implimented in the link tool but it doesnt allow me to choose the option for target. The whole top part of the link tool is disabled for me. Is this is a previlidge thing or a bug on upgrading? Really need to know this before before I show the customer 4.51 for the first time. /John
#14246
Mar 25, 2008 18:44
Vote:
 
The link tool is used for specifying the url of your property. However, since only the url itself will be used as the property value, the url is the only thing you can specify and the rest is disabled. All fields will be enabled when using the link tool to insert a link in the Editor (the main area of use of the link tool). To summarize, the disabled fields don't have anything to do with access rights and it isn't a bug - it's supposed to work this way. Best regards, Sarah Larsson
#14247
Mar 25, 2008 18:44
Vote:
 
I think this design/limitation can be an irritation. But in some projects we have simply added a new (custom) field which simple lets the user set target. Our code then uses the values of the two fields to get the desired effect.
#14248
Mar 25, 2008 18:44
Vote:
 
So in other words my customer is gonna shake his head in dismay...
#14249
Mar 25, 2008 18:44
Vote:
 
Two years on, EPiServer CMS 5, and this is still a big irritation! It isn't good, having to add the properties ourselves...
#14250
Mar 25, 2008 18:44
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.