Enabling add-on install

Vote:
 

Hello, just downloaded EpiServer CMS and installed the demo site Alloy.

I want to install the adds-ons to test them but I can't get the install button to show.

It also shows the message: "Please note that add-ons are configured to be managed by your site developer, but you can still browse the store." on the add ons page.

I created the WebAdmins and WebEditors roles and assigned it to the user. I also have the virtual rules:

        
        
        
        
        
        
        
        

Any suggestions?

#119220
Mar 24, 2015 20:50
Vote:
 

Which EPiServer version we are referring to here?

#119222
Mar 24, 2015 21:33
Vote:
 

Sorry: EpiServer 8

#119227
Mar 24, 2015 22:52
Vote:
 
<episerver.packaging installationMode="UI" />

This should do the trick!
#119228
Mar 24, 2015 23:07
Vote:
 

Thanks my friend! That was it...

#119229
Mar 24, 2015 23:25
Vote:
 

I do recommende that you install them from nuget instead of the admin interface. It will give you more and better control over them.

#119231
Mar 25, 2015 7:03
Vote:
 

You might want to read this article and some of the linked pages to get a better understanding: http://world.episerver.com/articles/Items/2-important-improvements-for-managing-addons-in-episerver/

#119232
Mar 25, 2015 8:02
Vote:
 

Yes, thanks guys. I was lazy enough to improve my answer. Think.. There definitely should be reason why EPiServer turned AddOn installation from UI off by default :) When you let AddOns to be managed by editors or admins an interesting mess may expect you ahead..

#119266
Mar 25, 2015 15:55
Vote:
 

Thank you all for the quick usefull comments. I'm new to EpiServer and just checking it out. I'll keep that in mind for when I'm really going to use it on a project.

#119267
Mar 25, 2015 16:14
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.