Disabling of External link interpretation


Hello, I faced with such problem. When I try to insert External link like this:

in content area in editor mode, EpiServer interprets it as reference to Retailers Page (page of type "Reatilers Page" is mapped to /retailers-page1/ url) and inserts this link instead:

http://www.sve-web.se/retailers-page1/retailerdetailpage/ what is wrong.

Please help to disable such strange behavior. May I switch off any interpretation of external links to get original url in the result (href), like:


Sep 30, 2014 14:20

Is www.sve-web.se your own site? Is it in the list of host name in your site settings in admin mode?

When you say "content area" do you mean a xhtmlstring property that you edit with the TinyMce editor?

Oct 04, 2014 0:27

Fredrik, yes, you are absolutely correct.

www.sve-web.se - that's local name of my own site. The hostname (www.sve-web.se) is added in site settings for Sweden locale.

Content area is xHtmlString property that I edit with TinyMce.

Oct 07, 2014 17:16

When you insert links to local content like pages or media EPiServer always try to converted it to a permanent link when it is stored in the database. This is not something you should try to disable.

If you add a link to a page and there is a number in the url segment EPiServer will try to resolve the number as a page id. That is probably what is happening in your case. This mechanisms exisit to handle routing if the UrlSegment property is empty on a page - something that could happen in japan and china if the page name does not contain any url firendly letters.

Oct 07, 2014 17:40
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.