Compatibility Issues with Upgrade

Member since: 2014
 

Hi,

We are currently in a large upgrade of a client site from 10 > 11.

As part of this we are also updating several add-ons.

We have run into a problem with upgrading 'Episerver.ConnectForCampaign' due to 'Episerver.Marketing.Automation.Forms'. Below is the error output:

Unable to resolve dependencies. 'Episerver.Marketing.Automation.Forms 2.0.0' is not compatible with 'EPiServer.ConnectForCampaign 1.1.0 

Has anyone had similar or experienced this issue before?

Thanks

Paul

#195036 Jul 11, 2018 15:31
  • Member since: 2010
     
    Hey Paul,
    I imagine that's because a merge or rebase got the versions of dependencies out of whack.
    Best thing to do would be:
     
    1. Remove current Campaign package. Check your project file to ensure that all references have been excluded from your solution
    2. Clear bin and packages folder
    3. Install most recent Campaign package. This should then install valid dependencies

     
    Let me know how you go.
    Cheers
    #195076 Edited, Jul 12, 2018 15:46