Unable to switch language in editor mode.

Wen
Wen
Vote:
 

Hi,

I am in the process of upgrading a Epi 7 multi language site to Epi 11, most of the upgrade went ok. Today i noticed a weird issue when switch language in editor mode.

In the old epi 7 site, I am able to switch to a different language via the language selector in editor mode. After the upgrade, this no longer works. Even if i switched the language via the site branch, it is still saying I am not able to edit the content in English and I am 100% sure the content exists in English and I am under English in site branch in editor mode.

And this is the error i am getting "You are working in English, this content is in dansk. To edit it, switch to dansk".

Has anyone had the same issue?

Thanks

#230359
Edited, Nov 04, 2020 19:44
Vote:
 

It's not really a solution, but you could try to switch language using Language Manager:
https://nuget.episerver.com/package/?id=EPiServer.Labs.LanguageManager


Then it's also easier to see available languages for every page.

#230439
Nov 05, 2020 10:30
Wen - Nov 05, 2020 16:41
Hi Thomas,
Thank you for the suggestion, I tried the gadgets, but I believe something is wrong with switching the language in episerver backend. When I switch to English,
the page tree in editor mode is still in Danish.
Wen
Wen
Vote:
 

Also I cant even translate a page anymore.

I checked all the requirements on https://world.episerver.com/blogs/ayman-elbadawy2/dates/2019/12/how-to-enable-episerver-11-for-multilingual/

Still no options to do translation.

#230449
Edited, Nov 05, 2020 21:57
Vote:
 

Hi Wen,

All the languuages enabled in "Manage Website Languages"?

#230470
Nov 06, 2020 7:11
Wen
Vote:
 

Hi Ravindra,

Yes, those are enabled with correct permission. I also made sure the root page had those language enabled for editing in language settings. 

#230494
Nov 06, 2020 15:11
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.