Animated Gif does not work in Global view

Vote:
 

I am using a content editor where i inserted gif image in my content. Animated gif works well when in editor mode but when content goes to Glocal mode(Published mode), animatino does not work. I use TinyMce editor V1.

Any help?

#207396
Sep 18, 2019 17:38
Vote:
 

Hi Vinu,

How you are rendering the "GIF" on the page. Can you please post the code here. It might be possible that is not creating the image url correctly.

Are you rendering this using below code?

  <img src="@Url.ContentUrl(Model.MobileImage)" />​

And if you are using it in the ContentReference then render it using

@Html.PropertyFor(m => m.MobileImage)

Thanks

Ravindra

#207397
Edited, Sep 18, 2019 19:03
Vinu - Sep 20, 2019 9:00
Hi Ravindra, Thanks for you reply. I have a requirement where i should use TextEditor. So user tried to use Gif image in the text editor and animated gif works well in editing mode . After publishing the content, in the global view Gif animation does not work. Thats the issue. The data type of property is XHTMLString
Vote:
 

Hi Vinu,

The issue seems here is with the allowed Image extensions, in you Image media, please check if gif is allowed.

[MediaDescriptor(ExtensionString = "jpg,jpeg,jpe,ico,gif,bmp,png")]

So, if its not in ExtensionString and still you drag it into your TinyMCE, then it changes the extension to something else like jpg or png (from allowed one) and then it don't work as expected.

Please let me know if it helps.

Thanks

#207451
Sep 20, 2019 8:55
Vinu - Sep 20, 2019 9:01
Hi Praful,

We have allowed all types of image formats. But animation in gif does work in published content.

Thanks.
Praful Jangid - Sep 20, 2019 9:05
Can you inspect in browser (at the place where it is not working) and confirm that the extension of image is still .gif and not anything else?
Vinu - Sep 20, 2019 9:07
Yes, image extension is Gif. But text editor adding some extra params for sizing like w & h(For width and height)
Praful Jangid - Sep 20, 2019 9:13
That param will not break the gif to work. But still you can try removing it from CMS edit mode.
Vinu - Sep 20, 2019 9:20
Yeah even if we remove, empty string are added in the link. I am trying to find a way to stop default resizing of image in the TinyMce editor. As gif image will lose its animation when resizing it.
Praful Jangid - Sep 20, 2019 9:26
So your image url is like this, right?
/contentassets/2723f6c5b2154052909b2714db5b3e3a/giphy.gif/?w=100&h=100
If yes, it is working in my site (in edit mode as well as published mode). It's not and issue of image resizing param.
Vinu - Sep 20, 2019 9:28
Oh Strange! It does not work for us.
Vote:
 

Can you add more details like, browser and it's version, episerver and Tinymce version. have you tried different gif images.
Your extension (MediaDescriptor(ExtensionString)) string details and your code that how you are rendering the image, for example

<img src="@Model.Url" alt="@Model.Name" title="@Model.Copyright" class="image-file">
#207461
Sep 20, 2019 9:35
Vote:
 

I may be asking a silly question here, Is the .gif being used as a background image of an element?

#207470
Sep 20, 2019 16:01
Vote:
 

Hi Vinu, I think I found the issue. The param "?w=" or whatever used for image resizing aren't supported with gif. If you remove that parameter for gif image, that should work. I tried that and it worked for me.

#207577
Sep 25, 2019 15:23
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.