Enable yellow screen of death

Vote:
 

Hello,

This is probably more of a generic .Net question, however, I thought I would post in here initially as it's an Episerver solution where I'm experiencing the problem.

I cannot enable the familar and developer-friendly "yellow screen of death" in an Episerver 10 solution I'm working on.

I've tried the following:

  • Switched errorMode to detailed in the WebConfig
<httpErrors errorMode="Detailed" existingResponse="Replace" >
  <clear/>
</httpErrors>
  • Set customErrors to Off (yes, with a captal O).
  • Set Episerver gloablErrorHandling to Off
  • Ensured debug is set to true
  • Disabled any HandleError filters which you would normally see in the Global.asax.cs - e.g. 
    filters.Add(new HandleErrorAttribute())​
  • Checked for any custom View rendering engines. There was one, but I've now disabled it.
  • Uninstalled any error handling modules that we had which could have buried it - such as ELMAH and Bvn404Handler.
  • Literally, been through every initialization module and disabled them. 

And so I'm at the point of desperation where one resorts to posting on a forum at 5.15pm on a Friday ;) 

Can anyone think of something I may have missed?

#206375
Edited, Aug 19, 2019 13:26
Vote:
 

Hi Jay

I have one more thing to check.

Have you logged in to Episerver as an admin? If not, then you may try that.

By default admins are allowed to see YSODs, while public users are not.

You can even grant that right to specific users and groups. Here’s how to do that.

#206379
Aug 18, 2019 15:18
Vote:
 

Try this:

existingResponse="Replace""PassThrough"

#206380
Aug 19, 2019 1:45
Jay Wilkinson - Aug 19, 2019 12:23
Great, that done the trick. Thanks Marcus! I guess this suggests that there is a lower-level error handler within the Episerver repository.

Useful to know for anybody else who may run into this problem.
Vote:
 

Marcus's suggestion should work, or you can simple remove the entire

<httpErrors errorMode="Detailed" existingResponse="Replace" > <clear/> </httpErrors>

section 

#206388
Aug 19, 2019 11:19
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.