Getting real-time connection message very often

Vote:
 

I am getting the below message very often. It does not prevent the CMS  to work though.

"A real-time connection could not be established with the server. This may be caused by incorrect configuration. Please see the User interface section in the user guide for further information."

#202420
Mar 26, 2019 10:46
Vote:
 

This is when you are running site without debug (ctrl+f5) and you change in code. Then you will need to refresh you website(CMS). That's all about the message is.

#202440
Mar 26, 2019 13:28
Vote:
 

It sounds like you didn't enable Websocket in IIS? 

#202442
Edited, Mar 26, 2019 13:49
Vote:
 

Hi Quan,

For that, do we need to have site hosted in IIS? Or this is applicable for any case (like running site as ctrl+f5)?

#202444
Mar 26, 2019 13:45
Vote:
 

I'm not 100% sure, but I would guess it'll be the same 

#202448
Mar 26, 2019 13:50
Vote:
 

I just verified that it (WebSocket Protocol) is enabled for me in IIS and I am running my site using ctrl+f5. I still see that popup in CMS everytime I do a code change/build.

#202450
Mar 26, 2019 13:57
Vote:
 

That's expected because when you build the site because it's basically a restart, and I would think WebSocket need to refresh/reestablish the handshake.

However if it pops up everytime as OP mentioned then you should look into enabling WebSocket 

#202451
Mar 26, 2019 14:06
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.