SQL server 2019 compatibility

Vote:
 


We want to upgrade our SQL server to 2019 in place. As we read here https://world.episerver.com/documentation/system-requirements/ there is no official statement regarding the compatability of "SQL server 2019"

Did anyone just tried it? I guess it should work? 

#211062
Dec 17, 2019 8:38
Vote:
 

I think you have to ask this to Episerver Support because they can give you the best answer.

#211066
Dec 17, 2019 9:36
Vote:
 

Well I guess asking it here makes it more public. Best would be that the system-requirements page is updated ;)

#211067
Dec 17, 2019 10:09
Vote:
 

Hi Holden, the Episerver system requirements page should be updated when ever there are changes to the supported OS/SQL/.NET Framework/Visual Studio versions.

So as the SQL 2019 is not currently listed it means it is not officially supported by Episerver.

But in theory you could use SQL Server 2019 and set the database compatibility level to 140 (SQL Server 2017) and it should just work. Most likely it would also work with mode 150 (SQL Server 2019) but as said it is NOT currently officially supported ;-)

Quan Mai might have insights to this support, is it coming anytime soon etc. Going to ping him if he could give us an answer here.

edit : Quan answered in Twitter: https://twitter.com/koodihahmo/status/1211585793568968704

#211289
Edited, Jan 01, 2020 14:34
Vote:
 

We are in the process of validating SQL server 2019 so not officially supported yet, but we don't anticipate any problems so we should be able to add it to the supported versions soon.

#211291
Dec 30, 2019 11:54
Vote:
 

Great news, SQL Server 2019 is now officially supported: https://twitter.com/PerGunsarfs/status/1214860810905956353

#211427
Jan 08, 2020 13:09
Vote:
 

...and the system requirements page has been updated as well.

#211436
Jan 08, 2020 15:10
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.