500 error in epi edit tab. Lazy loaded property value is not supported by the current property instance

Vote:
 

When bringing up episerver in edit mode, the page tree does not display and just keeps trying to load.

Browser Dev Tools shows this:

HTTP500: SERVER ERROR - The server encountered an unexpected condition that prevented it from fulfilling the request. (XHR)GET - localhost/EPiServer/cms/Stores/contentstructure/?referenceId=1&query=getchildren&typeIdentifiers=episerver.core.pagedata&allLanguages=true&sort()&dojo.preventCache=1575909858055

Pasting this in to the browser gets this error: "Lazy loaded property value is not supported by the current property instance"

localhost/EPiServer/cms/Stores/contentstructure/?referenceId=1&query=getchildren&typeIdentifiers=episerver.core.pagedata&allLanguages=true

I have written code to load all the pages in to memory. Once this is done. the tree can be edit page can be refreshed and show. Once the brower is closed, the tree does not load again. All of this has been done in localhost.

epi version: 11.13.2.0

The following code gets a timeout. It can't find root. If I call FindPagesWithCriteria on Start-Page then it works untill I close the browser.

IContentRepository repository = ServiceLocator.Current.GetInstance<IContentRepository>();
PageReference root = PageReference.RootPage;
IEnumerable<ReferenceInformation> references = repository.GetReferencesToContent(root, true).Take(1).ToList();

We also get this error under Admin->Config->Rebuild Name for Web Addresses

"Lazy loaded property value is not supported by the current property instance"

#210881
Edited, Dec 09, 2019 20:47
Vote:
 

Eric, did you replace the default implementation of IContentRepository or IContentLoader?

Can you share the code?

#210888
Dec 09, 2019 21:54
Vote:
 

We have not replaced IContentRepository or IContentLoader. We have a copy of this db woirking great. The only difference is we are switching to .Net Core.

Which code would you like to see?

#210889
Dec 09, 2019 21:56
Vote:
 

Eric. .NET Core, I do not think that is fully supporterd yet, at least not for the edit interface

#210895
Dec 10, 2019 8:59
Vote:
 

I just checked and we have six projects in our solution. One is .Net Core but we aren't using it yet.

#210904
Edited, Dec 10, 2019 15:09
Vote:
 

We have the issue fixed for now. We had moved all of our epi models (Block, Pages, etc) out of main project to their own project. This caused the issue. We have now moved them back to get it going but would like to have all the epi stuff contained in their own project.

#210905
Dec 10, 2019 15:54
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.