Unable to create blocks through content areas

Vote:
 

We have been experiencing some issues with creating blocks by clicking the "create"-link on content areas. The create-form is displayed, but when clicking the create-button we get an exception in the console. 

POST http://site/EPiServer/cms/Stores/contentdata/ 500 (Internal Server Error)

message: "Unable to load /EPiServer/cms/Stores/contentdata/ status: 500"

Followed by:

SyntaxError: Unexpected token '<'
    at Object.dojo.fromJson (dojo.js:formatted:9483)

When trying to create the block in the assets panel and draging it to the content area it works fine. 

An upgrade to the latest Episerver version didn't fix the issue unfortunately. 

#209564
Nov 18, 2019 16:11
Vote:
 

Do you have any custom validation on a property within the block you are creating, please see this following : 

https://world.episerver.com/support/Bug-list/bug/CMS-11522 

#209569
Nov 18, 2019 17:46
Pontus Johansson - Nov 19, 2019 12:05
This seems to be the issue, thanks Minesh!
Vote:
 

See following link contians the solution

https://support.episerver.com/hc/en-us/articles/360002910312-409-conflict-Creating-page-block

The exact status code may be different and your configuration might be changing the status code to 500.

If, this is not related, please also check the following link too

https://world.episerver.com/documentation/Release-Notes/ReleaseNote/?releaseNoteId=CMS-9148

Thanks

#209580
Nov 19, 2019 7:28
Vote:
 

Hi,

I am not sure about the exact issue but it might be related to Access rights?

Because when you create a block using contentArea create button it will use the "For This Page"/"For This Block" so make sure you have proper permission for these folders.\

Could you please mention the Episerver version here?

#209581
Nov 19, 2019 7:51
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.