Blobs are stored in app_data folder, regardless of custom blob fileshare definition

Vote:
 

Hi all,

I have an issue with Media blobs being stored on 2 different locations. I defined a custom blob location in the web.config:

<blob defaultProvider="fileShare">
<providers>
   <add name="fileShare" path="\{location}\blobs" type="EPiServer.Framework.Blobs.FileBlobProvider, EPiServer.Framework" />
</providers>
</blob>

Sometimes blobs are stored in this defined location correctly, but sometimes however the blobs are also stored in the App_Data folder, which I don't want. I just want to use the custom location, since we have a Load-balanced setup for production.

Is there an extra setting which i have to use to prevent it?

Similar topic in the past:

https://world.episerver.com/forum/developer-forum/-Episerver-75-CMS/Thread-Container/2014/11/configure-the-blob-path-in-a-load-balanced-environment/

#209598
Nov 19, 2019 12:26
Vote:
 

Double-check all of your environmental settings, Transformations including your development environments. Most probably one of the webserver, staging/testing or development machines is pointing to App_Data location.

/K

#209602
Nov 19, 2019 14:49
Vote:
 

I checked but all servers are pointing to a separate fileserver that are configured with the defaultProvider for the blob. The only thing extra in the <episerver.framework> tag is this:

<appData basePath="App_Data" />

#209605
Nov 19, 2019 15:12
Vote:
 

What are those 2 different paths can you share their path/location information?

#210121
Nov 20, 2019 20:52