CMS 6.1 Web App Setup issues

Member since: 2014
 

Hi,

I am trying to install one old web application whichis developed in CMS 6.1. But it gives me following error.

=======================

Server Error in '/' Application.

The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.IO.FileLoadException: The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)

Source Error: 

[No relevant source lines]


Source File: c:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\3f52facf\fedec6fd\App_global.asax.ylacdxz-.0.cs    Line: 0 

Stack Trace: 

[FileLoadException: The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)]
   System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMarkHandle stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName, ObjectHandleOnStack type) +0
   System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName) +70
   System.RuntimeType.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark) +40
   System.Type.GetType(String typeName) +30
   EPiServer.Framework.FrameworkInitialization.InitVirtualRoles() +229
   EPiServer.Framework.FrameworkInitialization.Initialize(InitializationEngine context) +53
   EPiServer.Framework.Initialization.InitializationEngine.InitializeModules() +338
   EPiServer.Framework.Initialization.InitializationEngine.Initialize(HostType hostType) +83
   EPiServer.Framework.Initialization.InitializationModule.Initialize(HostType hostType) +158
   EPiServer.Framework.Initialization.InitializationModule.FrameworkInitialization(HostType hostType) +62
   EPiServer.Global..ctor() +54
   Manpower.Applications.Inc.Web.Global..ctor() +28
   ASP.global_asax..ctor() in c:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\3f52facf\fedec6fd\App_global.asax.ylacdxz-.0.cs:0

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
   System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck) +0
   System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark) +119
   System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark) +232
   System.Activator.CreateInstance(Type type, Boolean nonPublic) +83
   System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, StackCrawlMark& stackMark) +1088
   System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +124
   System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture) +20
   System.Web.HttpRuntime.CreateNonPublicInstance(Type type, Object[] args) +60
   System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +260
   System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +296

[HttpException (0x80004005): Exception has been thrown by the target of an invocation.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +10075596
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +95
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +254


Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.7.3062.0

Please help me to fifure it out.

Many Thanks

Abhishek

#195859 Aug 09, 2018 15:23
  • Member since: 2010
     

    Hi Abhishek, just making sure you do have the Episerver Deployment center and correct Episerver CMS installed on the machine? So I guess in your case 6.1 means Episerver CMS 6 R2. In case you haven't installed the deployment center for CMS 6 R2, you can get it from here.

    #195873 Aug 09, 2018 20:21
  • Member since: 2014
     

    Thanks Annti for reply!

    I have installed the same even though it is not compatible with Windows ser 12 R2 and it is not compatble. But I continue istallation. It is working fine for my one of collegues VM but not for me.

    Any guess?

    Thanks

    Abhishek

    #195888 Aug 10, 2018 7:44