Connection strings defined in Azure Portal are still not picked up

Vote:
 

Hello

I did just now deploy an Alloy site to Azure (with version:  ) and I still neeeded the appsetting to make it read from the portal instead of the config file.

With a release note for this bug (that I reported) it says that it could not be fixed without a breaking change, but that was in version 8 so there has been two breaking after that so I thought it had been fixed. (I also heard from another developer that it was the same in version 11).

https://world.episerver.com/documentation/Release-Notes/ReleaseNote/?releaseNoteId=122518

Is this still the case, that you need to use this appsettings, and will you fix so you won't use it?

I do not want to save passwords in the transformation file, instead use the config tab in Azure

#189831
Mar 26, 2018 7:18
Vote:
 

what I don't understand fully - is why there are required breaking changes under the hood. where exactly?

#189946
Mar 27, 2018 22:13
Vote:
 

@Henrik - I have a 11.3 site running in Azure and I'm able to successfully use connection strings defined in the Portal. 

In my Release.config - I tranform the connectionStrings element to be empty:

  <connectionStrings xdt:Transform="Replace">

  </connectionStrings>

I then set the appSetting episerver:ReadOnlyConfigurationAPI to true in the Azure Portal and it uses my connection strings defined in the Portal.

No connection strings or secrets are in my Web.config or other config files. Am I missing something? I don't see the problem with adding a single appSetting to make this work - there are many other config settings that behave similarly to affect environment level configuration.

#190041
Mar 29, 2018 15:27
Vote:
 

Matt the thing I am thinking of is why this appsetting is needed: episerver:ReadOnlyConfigurationAPI

I know that in old versions of Epi, they read up all settings in the cache (and also saved a copy of web.config in the database I think) but I had hope that would have changed with the introduction of Azure support

#190354
Apr 10, 2018 9:05
Vote:
 

Is this still so, that we need this app setting?

#195044
Jul 12, 2018 7:49
Vote:
 

I am having the exact same problem. Monitoring.

episerver:ReadOnlyConfigurationAPI did fix it, but I had to restart app 2x for it to take. 

#205365
Edited, Jul 09, 2019 2:51
Vote:
 

Thanks Henrik for this thread, I had already forgotten this one and faced it again today ;-)

#207274
Sep 16, 2019 14:36
Vote:
 

Always glad to help Antti!! :)

#207277
Sep 16, 2019 14:43
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.