Images not rendering

Vote:
 

Set up the site first time and did not add the follows in web.config:


 
   
 


 
   
 

See no images on the site so added the above to the web config but still see no images. How to render images?

#177294
Apr 06, 2017 18:54
Vote:
 

Are you not seeing the images locally or in Azure?

#177297
Apr 06, 2017 19:41
Vote:
 

I see the images locally but not in Azure..

#177298
Apr 06, 2017 19:42
Vote:
 

I would recommend you download http://storageexplorer.com/ and add the account. You should be able to get the account key and name from the connection string section on the azure app service. See if that blob container exists on the cloud.

Looking at your config setting it looks like you are not using transforms which means every time you want to switch from local publish to azure publish you will have to update your web.config. The settings you have above only work for Azure publishing, not local.

I have the following setting in my Web.Release.config which is used for publishing to Azure.

  <episerver.framework createDatabaseSchema="true" xdt:Transform="SetAttributes(createDatabaseSchema)">
    <blob defaultProvider="azureblobs" xdt:Transform="Insert">
      <providers>
        <add name="azureblobs" type="EPiServer.Azure.Blobs.AzureBlobProvider,EPiServer.Azure" connectionStringName="EPiServerAzureBlobs" container="mysitemedia"/>
      </providers>
    </blob>
    <event defaultProvider="azureevents" xdt:Transform="Insert">
      <providers>
        <add name="azureevents" type="EPiServer.Azure.Events.AzureEventProvider,EPiServer.Azure" connectionStringName="EPiServerAzureEvents" topic="CFSEvents"/>
      </providers>
    </event>
  </episerver.framework>

The second option is to change the container & topic names in your config and re-publish to azure from VS. 

#177300
Apr 06, 2017 20:24
Vote:
 

I downloaded storage explorer. Am I suppoed to upload all the images there into the mysitemedia?

As for transforming web.config, yes I need to do that but first need to get the issue with the images resolved. Still not rendering images

#177303
Apr 06, 2017 22:23
Vote:
 

I wouldn't upload it from there. This is a tool to check if your blobs are uploaded correctly in the container. Did you try publishing with different container name? You can also reach out to managedservices@episerver.com to help you with these types of issues.

#177304
Apr 06, 2017 22:33
Vote:
 

So just this follows in web.config is supposed to populate all the images in the BLOB container in AZURE:

  <blob defaultProvider="azureblobs" xdt:Transform="Insert">
      <providers>
        <add name="azureblobs" type="EPiServer.Azure.Blobs.AzureBlobProvider,EPiServer.Azure" connectionStringName="EPiServerAzureBlobs" container="mysitemedia"/>
      </providers>
    </blob>
    <event defaultProvider="azureevents" xdt:Transform="Insert">
      <providers>
        <add name="azureevents" type="EPiServer.Azure.Events.AzureEventProvider,EPiServer.Azure" connectionStringName="EPiServerAzureEvents" topic="CFSEvents"/>
      </providers>
    </event>

I have that on the web.config so I am not sure why images are still not rendering. Any thing else I can try. Did cotnact Episerver Managed Services.

#177305
Apr 06, 2017 23:36
Vote:
 

Your container name for the blob is still the same 'mysiemedia' 😊

#177306
Apr 06, 2017 23:44
Vote:
 

And I assume you are using my settings in the transformed file not the web.config

#177307
Apr 06, 2017 23:46
Vote:
 

Hi,

Could it be that you are missing a connection string for blobs in Azure portal? http://prntscr.com/eun107

BR,

Marija

#177365
Apr 10, 2017 12:44
Vote:
 

The connection string is there in the Azure portsal. Uploaded the images on to mysitemedia. Still see no images rendering. 2 things, may be the way I am connecting to DB? or session being cached??

Aniket - what about the DB connection string in web.config with respect to transform? How do you have that defined in your web config release? Also whats the best practice on developing in LOCAL - so when developing in LOCAL you have a copy of the DB on LOCAL but you ignore that file on source control. And on the cloud you have the DB - what is the connection string (transform) on web.config?? Hope my question makes sense. I am confused on web.debug.config and web.release.config and the web.config. Which one is getting rednered on the integration environment??

#177393
Apr 10, 2017 21:01
Vote:
 

It's definitely not the connection string because your site loads up fine. 

When you publish to local you can select the "debug" configuration in your profile, so it uses your local DB connection string. You don't need the connection string for realease config if you are on the DXC cloud since you don't want to overwrite the connection string (I don't believe you can overwrite it).

Here's my connection string in web.debug.config so it only applies it to my local development.

<connectionStrings>
    <add name="EPiServerDB" connectionString="user id=username;password=somepassword;MultipleActiveResultSets=True;Data Source=ServerName;Database=DatabaseName" providerName="System.Data.SqlClient" xdt:Transform="SetAttributes" xdt:Locator="Match(name)" />
  </connectionStrings>

The best way to test web.config tranformations for debug & release is to publish to a local folder and see how it gets transformed by selecting these configurations in your publish profile. If it doesn't transform correctly something's not right.  

The question is - Did you browse using storageexplorer application to find the container name that has all your assets? The "container name" there has to match the container name in your web.config for the assets to show up correctly.

#177397
Edited, Apr 10, 2017 23:12
Vote:
 

I did browse and it was empty. So I upoaded all the folders in Static on there manually. Still saw no images. Also when I tried updating the web.config with different container names, I get this error:

Container names can contain only letters, numbers, and hyphens. The name must start with a letter or a number. The name can't contain two consecutive hyphens. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Configuration.ConfigurationErrorsException: Container names can contain only letters, numbers, and hyphens. The name must start with a letter or a number. The name can't contain two consecutive hyphens.

Was trying to use:

QDsitemedia

Not sure what else to do here??

#177399
Apr 11, 2017 0:38
Vote:
 

I dont think container names can have uppercase characters.

https://blogs.msdn.microsoft.com/jmstall/2014/06/12/azure-storage-naming-rules/

#177400
Apr 11, 2017 0:45
Vote:
 

Thanks. Changed the case:

<episerver.framework createDatabaseSchema="true" xdt:Transform="SetAttributes(createDatabaseSchema)">
    <blob defaultProvider="azureblobs" xdt:Transform="Insert">
      <providers>
        <add name="azureblobs" type="EPiServer.Azure.Blobs.AzureBlobProvider,EPiServer.Azure" connectionStringName="EPiServerAzureBlobs" container="qdsitemedia"/>
      </providers>
    </blob>
    <event defaultProvider="azureevents" xdt:Transform="Insert">
      <providers>
        <add name="azureevents" type="EPiServer.Azure.Events.AzureEventProvider,EPiServer.Azure" connectionStringName="EPiServerAzureEvents" topic="QdSiteEvents"/>
      </providers>
    </event>
  </episerver.framework>
 

and it seems to have created the folder - qdsitemedia in storage explorer but is empty - does not populate it with the objects/blobs..so what am i missing?

#177401
Apr 11, 2017 0:53
Vote:
 

http://world.episerver.com/digital-experience-cloud-service/deploying/deploying-an-existing-cms-site/

Ask Epi managed services to deploy the blobs to that container. Also, in your site settings make sure you have selected 'Use site specific assets'. You will then have to test by adding a new asset and publishing to Azure to see if it works for new assets.

#177402
Apr 11, 2017 2:12
Vote:
 

I will contact Epi Managed Services. On the Azure portal site settings, i dont see anywhere 'Use Site Specific assets' Where is this setting?

So one question I have is when you first deploy the EpiServer Alloy Site - all you have to do is add that blob tag in web.config rite?? That is supposed to add the images? that is how you add images? How else do you add images?

#177446
Apr 11, 2017 17:01
Vote:
 

This setting is within Epi CMS > admin > Manage websites > Click on the website.

#177525
Apr 13, 2017 20:42