EPiserver forms (Send email after submission) feature not working

Vote:
 

Hello,

I am trying to send email to user after form submission through episerver forms email template which is availble in form settings tab.

I have set the necessary information on the form on the settings tab and for configuring email server, for confirmation mail to work,In my web.config file I have done following settings - 


   
     
       
     
   
 


but I am unable to receive confirmation email on my email address.

Is I am missing something?

What are the complete steps that I have to follow to use EPiserver forms mail sending feature (Send email after submission).

Many thanks in advance.

#177322
Apr 07, 2017 13:26
Vote:
 

Seems like a gmail issue more than epi. Can you try with a different smtp server? If not, try this:

http://docs.mailpoet.com/article/61-sending-with-gmail-doesnt-work

Aniket

#177325
Apr 07, 2017 14:55
Vote:
 

@Aniket 

I have tried with differnet smtp server.But still I am not receiving any mail.

#177350
Apr 10, 2017 9:23
Vote:
 

Hi, Aman,

Do you have any errors in the log file when you try to send the email?

Normally, this works out of the box with Episerver Forms when you set up the form itself to send emails, nothing much to configure (other than SMTP settings).

I usually verify that this is working by running smtp4dev and then changing the settings to:

  <system.net>
    <mailSettings>
      <smtp deliveryMethod="Network" from="Test - test <test@test.com>">
        <network host="localhost" port="25" />
      </smtp>
    </mailSettings>
  </system.net>

BR,

Marija

#177364
Apr 10, 2017 12:35
Vote:
 

Hi Marija,

Thanks for reply.

No, i don't have any errors in my log file and I have also verified in smtp4dev with the proper settings in web.config. and it is working in smtp4dev.

But still I am not getting any confirmation email.

But I am getting forms error on console which says

Uncaught ReferenceError: epi is not defined
at initializeOnRenderingFormDescriptor (GetFormInitScript:6)
at GetFormInitScript:30

does this error can cause an issue in receiving email confirmation.

#177367
Apr 10, 2017 13:51
Vote:
 

Hi,

Most probably the error you see in console doesn't have anything to do with emails not being sent. Especially, if the emails are caught with smtp4dev. This indicates that your smtp settings are not working. You can give this a try by sending an email somewhere yourself (outside of Forms).

As for the console error, you are probably missing these:

@Html.RequiredClientResources("Header") and @Html.RequiredClientResources("Footer")

in _Root.cshtml.

#177370
Apr 10, 2017 14:02
Vote:
 

To separate out issues try local delivery first if that is working it is smtp setup issue not episerver.

<system.net>
	<mailSettings>
		<smtp deliveryMethod='SpecifiedPickupDirectory'>
			<specifiedPickupDirectory pickupDirectoryLocation="c:\projects\maildrop" />
		</smtp>
	</mailSettings>
</system.net>
#177395
Apr 10, 2017 22:47
Vote:
 

In order to complete Brian Choi's answer: Efter du set upp this meildrop solution, you need to change the transformation of the web.config file för other invironment like the following:

<system.net xdt:Transform="Replace">
  <mailSettings>
   <smtp>
     <network host="xxx.xx.xxx.xxx" />
   </smtp>
 </mailSettings>
</system.net>

#177739
Apr 18, 2017 16:38
Vote:
 
#177748
Apr 18, 2017 21:46
Vote:
 

Hello,

The following server settings are working properly.

<system.net>
<mailSettings>
<smtp deliveryMethod="network" deliveryFormat="SevenBit" from="validemail@gmail.com">
<network
host="smtp.gmail.com"
port="587"
defaultCredentials="false"
userName="username"
password="password"
enableSsl="true"
/>
</smtp>
</mailSettings>
</system.net>



Actually might be there were some issues with our server settings, but these smtp server setting are working fine and I am receiving confirmation email after submission.

Also, @MarijaJemuovic first answer was correct and @BrianChoi method for checking at local delivery first is helpful.

Thank you everyone for your time and help. :)

#177919
Edited, Apr 24, 2017 13:56
Vote:
 

Finally done with the same setting stated at the starting of post. I think the day was not good when we started to implement this.wink

#177920
Apr 24, 2017 13:57
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.