BVN 404 handler Custom Redirects not working.

Vote:
 

I have added a couple of custom redirects that don't work. The old url will not redirect to the new one, even though it says it has been added and saved in the dashboard module. The weird thing is that when I set the wildcard option to true it works.

I'm using relative urls btw, tried with absolute ones but that didn't work either. I have followed Jon D Jones guide on how to setup this plugin properly, (Guide by Jon D Jones). I have installed this plugin on a site a while ago but didn't encountered this problem back then. Am I missing som obvious configuration step here or what? Or has something changed in the new EPiServer updates?

The current versions I'm using is 9.12.0 for EPiServer CMS and 9.8.2 for the UI. 

Thanks in advance. 

Another thing that just happened. Even though I uncheck the wildcard option it still gets treated like one. 

For example:

OldUrl: /testurl

NewUrl: /testurl2

Then, if i type in www.hostname.com/testurl nothing happens. 

But if I type www.hostname.com/testurl plus a additional char, it redirects to the newurl defined in the bvn manager. 

#152292
Edited, Aug 23, 2016 12:24
Vote:
 

...or feel free to try out SEO Manager which will do the same and more :)

#152294
Aug 23, 2016 13:17
Vote:
 

... But SEO Manager isn't free ;-)

Carl, which version of the 404 handler is this? 
Have you tried with a static 404 page? 
Or made sure it is not simply browser cached? (Gotta ask!)

#152296
Aug 23, 2016 13:53
Vote:
 

The version I'm using is 4.1.1. Yeah, I've tried with the default notfound.aspx page and I got the same result.

 Regarding browser cache I've restarted the browser and (even the IIS) several times but the behavior is still the same :/. 

#152297
Aug 23, 2016 14:22
Vote:
 

Is the actual 404 page displayed as it should? Or is just the redirects that does not work?

#152300
Aug 23, 2016 14:28
Vote:
 

The 404 page is working, Static as well as custom implemented. It is only the Custom redirects added inside the gadget that seems to have a life of its own. I have installed it on a similiar site, with the same setup, and on that one it's working "flawlessly". I've tried to look in the IIS to see if there's some setting in there that's causing this problem but so far I have not found any. 

#152301
Aug 23, 2016 14:36
Vote:
 

Try turning off episervers globalerrorhandling in web.config. 

<episerver>
   <applicationSettings globalErrorHandling="Off" ...

That helps sometimes when you are redirecting 404s and have problems...

@Per Nothing great in life is for free you know :)

#152302
Aug 23, 2016 14:54
Vote:
 

I don't have problems with the 404 redirect,  the problem lies within the custom redirects.For example http://www.host.com/oldulr should point to http://www.host.com/newurl, this  is whats not working.

 

#152304
Aug 23, 2016 15:05
Vote:
 

Yup but depending on how they built it the above can affect it...

#152305
Aug 23, 2016 15:16
Vote:
 

I suggest you turn on extra logging for the module. Modify your log configuration with the following snippet:

<logger name="BVNetwork.NotFound"
            additivity="false">
    <level value="All" />
    <appender-ref ref="debugLogAppender"/>
</logger>

Perhaps you'll find the answer there.

#152310
Aug 23, 2016 19:21
Vote:
 

Also, do you have a lot of existing redirects stored? Could there be some old suspicious redirects causing the issue perhaps? Check with fiddler to see if you actually get a 404 or 301

#152311
Aug 23, 2016 19:29
Vote:
 

Okay I tried to trace this with fiddler and found a rather strange problem. When trying to redirect from an existning page I end up with a regular 200 (doesn't work at all). But when I redirect from a url that does not exist, like /duhahdasd, it works and performs the desired redirect but the response code is still 200 and not 301.

I've scanned through web.config for redirects and there is none to be found. This issue persists over multiple servers so i doubt there is something in the IIS that's causing this. 

The 404 ones is still working as expected though.

#152319
Aug 24, 2016 8:58
Vote:
 

What do you mean when you say "redirect from an existing page"? Redirects will only work when there is a 404 error, so if you add a redirect where the old url is an existing url, it will never do the redirect.

Strange that you got a 200 though. Make sure you included the existingResponse setting in the httpErrors section:

<httpErrors errorMode="Custom" existingResponse="Replace">

It's a long shot, but have you recently upgraded the module? Could there be old dlls from an older version of the module? The dlls had a different name in an older version. 

Edit: 200, not 301.

#152320
Edited, Aug 24, 2016 9:24
Vote:
 

If you want to redirect an existing page, you can use Episervers standard functionality with shortcuts instead btw. Important for SEO of course that you actually get the 301 status.

#152321
Aug 24, 2016 9:33
Vote:
 

Carl, did you solve this? I got the same problem, but only when changing from urls with sub urls, for example: old -> http://website.com/category/category1 new -> http://website.com/category/category2

Does anyone have the same problem?

Of course I could point them with the in-built redirect helper but sometimes we deleted the old url so we need the BVN 404 handler Custom Redirects to work :/ anyone?

#199231
Nov 20, 2018 22:10
Vote:
 

Hi Alex and Carl,

I am facing the similar problem. Did anyone solved this? Please hlpe me out.

#206744
Aug 29, 2019 12:44
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.