Notification settings for content collaboration don't work?

Member since: 2010

Hi,

To begin with, I have the following Episerver / Content Collaboration add-on versions:

id="EPiServer.CMS" version="9.10.0"

id="EPiServer.CMS.UI" version="9.6.2"

id="EPiServer.ContentCollaboration" version="1.2.0.9000"

These are the settings for an item:

http://prntscr.com/bbwb14

http://prntscr.com/bbwba0

(Never send emails + For this item: none)

However, the emails are being sent for everything - when I create a draft, when I publish... Any ideas why? 

Thx a lot in advance!!

#149574 Jun 03, 2016 17:01
  • Hi.

    I simulated the environment like you described in the post above and tested the function. I saw that it still works properly. As I debugged, I saw that the code segment to check email settings (always send an email or never, etc) returns the correct result. Can you give me more details? From my experience with CC add-on when I fixed some bugs for clients, your settings  related to database or other middlewares may cause the add-on not to work as expected.

    Hung Phan.

    #150165 Jun 13, 2016 11:27
  • Member since: 2010

    Hi, Hung,

    Thank you so much for your investigation and efforts.

    The issue is the following, after further investigation:

    1. I set For this item: None and Email notifications: Never send emails

    2. I start editing the page and as soon as I do that, the setting gets reset to "This version until published". The email notification stay at "Never send emails", but I do get two emails:

    You have had notifications from Content Collaboration on the content [some content link]. Please go to the content to see more details.
    Below are some latest activities:
    [myusername] Created a Draft
    [myusername] Published
    [myusername] started editing 

    and

    You have had notifications from Content Collaboration on the content [some content link]. Please go to the content to see more details.
    Below are some latest activities:
    [myusername] started editing 

    It's strange that I get the email while I am on the page with the setting "Never send emails".

    I have tested this on Azure, locally and on a normal server. I am using Owin, but I have rewritten Owin membership / role provider not to require HTTP context, so all methods GetUser/GetUsers/GetRoles/etc work without exceptions.

    #150170 Jun 13, 2016 11:55
  • Hi.

    The last month, I supported a client to integrate the CC-addon into their site. At the end, one of developers of that company said that they would have to rewrite Owin membership/role rovider for the email notification function to fully integrate the add-on. Is it also your company?. If yes, could you please send me your latest code; I need to debug to know more about the issue. If not, from my experience with the customer I wrote above, the use of owin significantly interupt the data processing of the CC-addon. I think that I need your code to debug for more details.

    Hung Phan.

    Best Regards. 

    #150173 Edited, Jun 13, 2016 12:15
  • Member since: 2010

    Hi, yes, that's me, but please delete the client name in the post.

    I can send you the latest code, should I attach it to the same support issue?

    #150174 Jun 13, 2016 12:19
  • Hi.

    You can do it or upload on FTP site. If I remember correctly, the project size is quite heavy and the last time, Huy Le of support team had to upload source code on FTP site.

    Note: the client name and its site information is deleted.

    Best Regards.

    Hung Phan.

    #150175 Edited, Jun 13, 2016 12:23
  • Member since: 2010

    Hi,

    The issue on support is update, thx in advance!

    Marija

    #150184 Jun 13, 2016 14:29
  • I got your project and started to debug every single line of code of the CC addon. After the initial investigation, I saw that the function CanNotify to check your setting (always send an email or never) works properly, therefore, the function sendEmail is not reached. If I chose the option "Always send an email", I received an email notifying the new content (my epi server email address) and in case that I took the one "never", no email sent to me after I made a new comment. 

    I followed this process to test your code:

    1. Login.

    2. Access CMS by clicking on Epi banner on the top of the page.

    3. Add CC.

    4. Start setting email notification.

    5. Post comments or edit properties of some pages and publish them all. 

    About editting the page, I may not do it correctly. I need more information about how you do it for further investigation. I will try to talk with Huy this afternoon for more information and let you know if we find out something.

    Hung Phan.

    Best Regards.

    #150218 Edited, Jun 14, 2016 9:54
  • Member since: 2010

    hI, Hung,

    This is what I do (all in the same session, with the same user):

    1. Log in, go to, ex. Start page

    2. Set: For this item: None and Email notifications: Never send emails

    3. Start editing that page.

    I get two emails described above. Don't you? (might need smtp settings or smtp4dev)

    #150225 Edited, Jun 14, 2016 11:58
  • Hi Marija

    this is the email I received in case I chose the option  "always send an email":

    You have had notifications from Content Collaboration on the content  "....". Please go to the content to see more details.
    Below are some latest activities:
    You wrote: aaaa
    You wrote: bbaaccddhheeffhh
    You wrote: aaaaertert.

    The format is quite similar to you; therefore, I think that my smtp configuration is correct. A note here is that I used my epi server email instead of servicedesk.

    I will follow your procedures to test the add-on now :). 

    -----

    Removed unnecessary things :).

    #150226 Edited, Jun 14, 2016 12:11
  • Member since: 2010

    Please remove the client name once more, thx (from the link name and URL). Thx, great, let me know.

    #150227 Jun 14, 2016 12:13
First   1 2   Last